summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorGerhard Weis <g.weis@griffith.edu.au>2017-07-05 20:54:03 +1000
committerGerhard Weis <g.weis@griffith.edu.au>2017-07-05 20:54:03 +1000
commit0d0abd79a975ed132a8eb43783f87cd84eea9267 (patch)
tree733231867f0ff1ba3679e1d4564a1b2506353cb2 /setup.py
parent1dc3c2481ba32e9dbcad9e55d2c20281f5aa5756 (diff)
parent6e5802bf7b410551f1dfcaf6ede8638f0f233cad (diff)
downloadisodate-0d0abd79a975ed132a8eb43783f87cd84eea9267.tar.gz
Merge branch 'master' of https://github.com/lmazuel/isodate
# Conflicts: # .travis.yml # setup.cfg # src/isodate/tzinfo.py
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py15
1 files changed, 2 insertions, 13 deletions
diff --git a/setup.py b/setup.py
index fac49a0..e663b95 100644
--- a/setup.py
+++ b/setup.py
@@ -26,20 +26,10 @@
# CONTRACT, STRICT LIABILITY, OR TORT
##############################################################################
import os
-import sys
+from setuptools import setup
setupargs = {}
-
-try:
- from setuptools import setup
- setupargs['test_suite'] = 'isodate.tests.test_suite'
- if sys.version[0] == '3':
- setupargs['use_2to3'] = True
-except ImportError:
- from distutils.core import setup
- if sys.version[0] == '3':
- from distutils.command.build_py import build_py_2to3
- setupargs['cmdclass'] = {'build_py': build_py_2to3}
+setupargs['test_suite'] = 'isodate.tests.test_suite'
def read(*rnames):
@@ -72,7 +62,6 @@ setup(name='isodate',
'License :: OSI Approved :: BSD License',
'Operating System :: OS Independent',
'Programming Language :: Python',
- 'Programming Language :: Python :: 2.6',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: 3.4',