summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerhard Weis <g.weis@griffith.edu.au>2014-02-27 11:31:53 +1000
committerGerhard Weis <g.weis@griffith.edu.au>2014-02-27 11:31:53 +1000
commitb31c424c8183b3c4ab06bddb300b04425bdde914 (patch)
tree54aef2fe8f0086f21239661597f1f0dc58c60d54
parent80a8e6d13778252f626dfb8d7503648335e23482 (diff)
downloadisodate-b31c424c8183b3c4ab06bddb300b04425bdde914.tar.gz
run flake and coverage tests via tox
-rw-r--r--.travis.yml7
-rw-r--r--tox.ini17
2 files changed, 22 insertions, 2 deletions
diff --git a/.travis.yml b/.travis.yml
index 348fb75..57cb05c 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -10,6 +10,8 @@ env:
- TOX_ENV=py32
- TOX_ENV=py33
- TOX_ENV=pypy
+ - TOX_ENV=flake
+ - TOX_ENV=cover
install:
- pip install tox
@@ -17,3 +19,8 @@ install:
script:
- tox -e $TOX_ENV
+after_script:
+ - if [ $TOXENV == "cover" ]; then
+ pip install --queiet --use-mirrors coveralls
+ coveralls;
+ fi
diff --git a/tox.ini b/tox.ini
index 02dd2ed..cebdf4d 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,7 +1,20 @@
[tox]
-envlist = py26,py27,py32,py33,pypy
+envlist = py26,py27,py32,py33,pypy,flake,cover
[testenv]
deps =
commands =
- python setup.py test
+ {envpython} setup.py test
+
+[testenv:flake]
+basepython = python2.7
+commands=
+ pip install --quiet flake8
+ {envpython} setup.py clean --all flake8
+
+[testenv:cover]
+basepython = python2.7
+commands =
+ pip install --quiet coverage
+ {envpython} setup.py clean --all
+ coverage run setup.py test