summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHugo van Kemenade <hugovk@users.noreply.github.com>2021-12-13 01:00:55 +0200
committerHugo van Kemenade <hugovk@users.noreply.github.com>2021-12-13 08:19:01 +0200
commit8431ea97a43be74889121b3f1df6a11b968c5bf7 (patch)
treed078df3817cc634b2d83110050d7cdfcc6507c75
parenteb9cdc70be731e458d9063e914fd23695959bc2c (diff)
downloadisodate-8431ea97a43be74889121b3f1df6a11b968c5bf7.tar.gz
Simplify cache config
-rw-r--r--.github/workflows/lint.yml2
-rw-r--r--.github/workflows/test.yml17
2 files changed, 3 insertions, 16 deletions
diff --git a/.github/workflows/lint.yml b/.github/workflows/lint.yml
index 6f8c677..5b01bde 100644
--- a/.github/workflows/lint.yml
+++ b/.github/workflows/lint.yml
@@ -9,4 +9,4 @@ jobs:
steps:
- uses: actions/checkout@v2
- uses: actions/setup-python@v2
- - uses: pre-commit/action@v2.0.2
+ - uses: pre-commit/action@v2.0.3
diff --git a/.github/workflows/test.yml b/.github/workflows/test.yml
index 098d327..4ebcf46 100644
--- a/.github/workflows/test.yml
+++ b/.github/workflows/test.yml
@@ -26,21 +26,8 @@ jobs:
uses: actions/setup-python@v2
with:
python-version: ${{ matrix.python-version }}
-
- - name: Get pip cache dir
- id: pip-cache
- run: |
- echo "::set-output name=dir::$(pip cache dir)"
-
- - name: Cache
- uses: actions/cache@v2
- with:
- path: ${{ steps.pip-cache.outputs.dir }}
- key:
- ${{ matrix.os }}-${{ matrix.python-version }}-v1-${{
- hashFiles('**/setup.py') }}
- restore-keys: |
- ${{ matrix.os }}-${{ matrix.python-version }}-v1-
+ cache: pip
+ cache-dependency-path: "setup.py"
- name: Install dependencies
run: |