summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHugo van Kemenade <hugovk@users.noreply.github.com>2021-09-13 11:56:21 +0300
committerHugo van Kemenade <hugovk@users.noreply.github.com>2021-09-13 11:56:21 +0300
commit40d929fbb26bf44222fa44d0ff10a675d0eb1adc (patch)
tree705ec8defbc99465b36e75657ef81331a3dad4fc
parent6923aee503ac81c26d2425592e90a2254c7666d9 (diff)
downloadisodate-40d929fbb26bf44222fa44d0ff10a675d0eb1adc.tar.gz
Add support for Python 3.10
-rw-r--r--.github/workflows/test.yml4
-rw-r--r--setup.py4
-rw-r--r--tox.ini2
3 files changed, 7 insertions, 3 deletions
diff --git a/.github/workflows/test.yml b/.github/workflows/test.yml
index bab2ac2..ee55d7c 100644
--- a/.github/workflows/test.yml
+++ b/.github/workflows/test.yml
@@ -11,7 +11,7 @@ jobs:
strategy:
fail-fast: false
matrix:
- python-version: ["3.6", "3.7", "3.8", "3.9", "pypy3"]
+ python-version: ["3.6", "3.7", "3.8", "3.9", "3.10-dev", "pypy3"]
os: [ubuntu-latest, macos-latest, windows-latest]
include:
# Include new variables for Codecov
@@ -53,7 +53,7 @@ jobs:
tox -e py
- name: Upload coverage
- uses: codecov/codecov-action@v1
+ uses: codecov/codecov-action@v2
with:
flags: ${{ matrix.codecov-flag }}
name: ${{ matrix.os }} Python ${{ matrix.python-version }}
diff --git a/setup.py b/setup.py
index e39446f..12ee044 100644
--- a/setup.py
+++ b/setup.py
@@ -67,6 +67,10 @@ setup(name='isodate',
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3.8',
+ 'Programming Language :: Python :: 3.9',
+ 'Programming Language :: Python :: 3.10',
'Programming Language :: Python :: Implementation :: PyPy',
'Topic :: Internet',
('Topic :: Software Development :'
diff --git a/tox.ini b/tox.ini
index cd25d99..414fda5 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,7 +1,7 @@
[tox]
envlist =
lint
- py{36, 37, 38, 39, py3}
+ py{36, 37, 38, 39, 310, py3}
[testenv]
deps =