summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJose Eduardo <jose.eduardo.gd@gmail.com>2019-07-19 16:21:56 +0100
committerJose Eduardo <jose.eduardo.gd@gmail.com>2019-07-19 16:21:56 +0100
commit40358ac82b948ea8377d5ca32b576def31b39a84 (patch)
tree198f0b80c4f0d2ae940ad2b7f6fb8ee2c783ae68
parent27cebc56a0f6a900eeb897512879d545095f410b (diff)
downloadisodate-40358ac82b948ea8377d5ca32b576def31b39a84.tar.gz
Avoid unclosed file warning
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index e39446f..9634625 100644
--- a/setup.py
+++ b/setup.py
@@ -30,7 +30,8 @@ from setuptools import setup
def read(*rnames):
- return open(os.path.join(os.path.dirname(__file__), *rnames)).read()
+ with open(os.path.join(os.path.dirname(__file__), *rnames)) as read_file:
+ return read_file.read()
setup(name='isodate',