summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerhard Weis <g.weis@uq.edu.au>2021-12-13 08:08:07 +1000
committerGerhard Weis <g.weis@uq.edu.au>2021-12-13 08:08:07 +1000
commit25fb6392f9569c962a12eb4eddbbd7a883877fd6 (patch)
tree9cd3baa710921933a4ce3c8f0658d2b310844a50
parent07d1602048083415bc22dc72cff152c9c2e0e021 (diff)
downloadisodate-25fb6392f9569c962a12eb4eddbbd7a883877fd6.tar.gz
bump version
remove end-of-life python versions
-rw-r--r--.github/workflows/test.yml2
-rw-r--r--CHANGES.txt6
-rw-r--r--setup.py3
-rw-r--r--tox.ini2
4 files changed, 8 insertions, 5 deletions
diff --git a/.github/workflows/test.yml b/.github/workflows/test.yml
index bb86e7c..098d327 100644
--- a/.github/workflows/test.yml
+++ b/.github/workflows/test.yml
@@ -11,7 +11,7 @@ jobs:
strategy:
fail-fast: false
matrix:
- python-version: ["3.6", "3.7", "3.8", "3.9", "3.10", "pypy3"]
+ python-version: ["3.7", "3.8", "3.9", "3.10", "pypy3"]
os: [ubuntu-latest, macos-latest, windows-latest]
include:
# Include new variables for Codecov
diff --git a/CHANGES.txt b/CHANGES.txt
index 5bdee49..ffee69d 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -2,6 +2,12 @@
CHANGES
=======
+0.7.0 (unreleased)
+------------------
+
+- drop end of life python versions
+
+
0.6.1 (2021-12-13)
------------------
diff --git a/setup.py b/setup.py
index 3a2a97b..08f88fb 100644
--- a/setup.py
+++ b/setup.py
@@ -61,10 +61,7 @@ setup(name='isodate',
'License :: OSI Approved :: BSD License',
'Operating System :: OS Independent',
'Programming Language :: Python',
- 'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: 3.9',
diff --git a/tox.ini b/tox.ini
index 13b3e90..4410e0f 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,7 +1,7 @@
[tox]
envlist =
lint
- py{27, 36, 37, 38, 39, 310, py3}
+ py{37, 38, 39, 310, py3}
[testenv]
deps =