summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabriel Falcão <gabriel@nacaolivre.org>2021-05-21 01:32:22 +0200
committerGabriel Falcão <gabriel@nacaolivre.org>2021-05-21 01:34:38 +0200
commitb5f71c96c05c92f81c9d13ee71d991f9f9d5e383 (patch)
tree5ac32fc78b1c026075f8c4c8e0870631d4e02394
parent0b74a861dedb8e4cf1574e20c7f95a5334f790b2 (diff)
downloadhttpretty-b5f71c96c05c92f81c9d13ee71d991f9f9d5e383.tar.gz
💅
-rw-r--r--Makefile3
-rw-r--r--tests/bugfixes/nosetests/test_388_unmocked_error_with_url.py2
-rw-r--r--tests/bugfixes/nosetests/test_414_httpx.py1
-rw-r--r--tests/bugfixes/nosetests/test_416_boto3.py1
-rw-r--r--tests/bugfixes/nosetests/test_417_openssl.py2
5 files changed, 6 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 5c5cae2..9f8f20a 100644
--- a/Makefile
+++ b/Makefile
@@ -41,9 +41,8 @@ pyopenssl: $(VENV)/bin/nosetests
$(VENV)/bin/nosetests --cover-erase tests/pyopenssl
bugfixes: $(VENV)/bin/nosetests $(VENV)/bin/pytest # runs tests for specific bugfixes
- $(VENV)/bin/pytest -v --maxfail=1 --mypy tests/bugfixes/pytest
$(VENV)/bin/nosetests tests/bugfixes/nosetests
-
+ $(VENV)/bin/pytest --maxfail=1 --mypy tests/bugfixes/pytest
# runs functional tests
functional: $(VENV)/bin/nosetests # runs functional tests
diff --git a/tests/bugfixes/nosetests/test_388_unmocked_error_with_url.py b/tests/bugfixes/nosetests/test_388_unmocked_error_with_url.py
index 751d0ad..ff8b756 100644
--- a/tests/bugfixes/nosetests/test_388_unmocked_error_with_url.py
+++ b/tests/bugfixes/nosetests/test_388_unmocked_error_with_url.py
@@ -38,7 +38,7 @@ def http():
@httpretty.activate(allow_net_connect=False)
def test_https_forwarding():
- "UnmockedError is raised with details about the mismatched request"
+ "#388 UnmockedError is raised with details about the mismatched request"
httpretty.register_uri(httpretty.GET, 'http://google.com/', body="Not Google")
httpretty.register_uri(httpretty.GET, 'https://google.com/', body="Not Google")
response1 = http().get('http://google.com/')
diff --git a/tests/bugfixes/nosetests/test_414_httpx.py b/tests/bugfixes/nosetests/test_414_httpx.py
index 6360ddc..889b871 100644
--- a/tests/bugfixes/nosetests/test_414_httpx.py
+++ b/tests/bugfixes/nosetests/test_414_httpx.py
@@ -4,6 +4,7 @@ from sure import expect
@httpretty.activate(verbose=True, allow_net_connect=False)
def test_httpx():
+ "#414 httpx support"
httpretty.register_uri(httpretty.GET, "https://blog.falcao.it/",
body="Posts")
diff --git a/tests/bugfixes/nosetests/test_416_boto3.py b/tests/bugfixes/nosetests/test_416_boto3.py
index 9d11eaa..8db807b 100644
--- a/tests/bugfixes/nosetests/test_416_boto3.py
+++ b/tests/bugfixes/nosetests/test_416_boto3.py
@@ -7,6 +7,7 @@ from sure import expect
@httpretty.activate(allow_net_connect=False, verbose=True)
def test_boto3():
+ "#416 boto3 issue"
httpretty.register_uri(
httpretty.PUT,
"https://foo-bucket.s3.amazonaws.com/foo-object",
diff --git a/tests/bugfixes/nosetests/test_417_openssl.py b/tests/bugfixes/nosetests/test_417_openssl.py
index 29d82da..750a3fc 100644
--- a/tests/bugfixes/nosetests/test_417_openssl.py
+++ b/tests/bugfixes/nosetests/test_417_openssl.py
@@ -17,6 +17,7 @@ except Exception:
@skipIf(extract_from_urllib3 is None,
"urllib3.contrib.pyopenssl.extract_from_urllib3 does not exist")
def test_enable_disable_httpretty_extract():
+ "#417 urllib3.contrib.pyopenssl enable -> disable extract"
expect(urllib3.util.IS_PYOPENSSL).to.be.false
httpretty.enable()
httpretty.disable()
@@ -24,6 +25,7 @@ def test_enable_disable_httpretty_extract():
expect(urllib3.util.IS_PYOPENSSL).to.be.false
def test_enable_disable_httpretty():
+ "#417 urllib3.contrib.pyopenssl enable -> disable extract"
expect(urllib3.util.IS_PYOPENSSL).to.be.false
httpretty.enable()
httpretty.disable()