summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabriel Falcão <gabriel@nacaolivre.org>2021-05-14 02:41:24 +0200
committerGabriel Falcão <gabriel@nacaolivre.org>2021-05-14 02:41:24 +0200
commit83159c26be83580577f5e129197c7445a38ae30f (patch)
tree7ed15ecc8ebbf2e22bbd5bb761ab66c7d489fa37
parente03ab7b9aa37c08d436121ff21d770064a443efd (diff)
downloadhttpretty-83159c26be83580577f5e129197c7445a38ae30f.tar.gz
update makefile
-rw-r--r--Makefile5
-rw-r--r--development.txt1
2 files changed, 3 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 3712aef..9a70f5f 100644
--- a/Makefile
+++ b/Makefile
@@ -23,8 +23,8 @@ setup $(VENV)/bin/sphinx-build $(VENV)/bin/twine $(VENV)/bin/nosetests $(VENV)/b
$(VENV)/bin/pip install -e .
# Runs the unit and functional tests
-tests: $(VENV)/bin/nosetests # runs all tests
- $(VENV)/bin/nosetests tests --with-random --cover-erase
+tests: unit functional pyopenssl
+
tdd: $(VENV)/bin/nosetests # runs all tests
$(VENV)/bin/nosetests tests --with-watch --cover-erase
@@ -38,7 +38,6 @@ unit: $(VENV)/bin/nosetests # runs only unit tests
pyopenssl: $(VENV)/bin/nosetests
- $(VENV)/bin/pip install ndg-httpsclient
$(VENV)/bin/nosetests --cover-erase tests/pyopenssl
diff --git a/development.txt b/development.txt
index 8977c86..fb46b3e 100644
--- a/development.txt
+++ b/development.txt
@@ -26,3 +26,4 @@ tox>=3.14.5
twine>=1.15.0
urllib3>=1.25.8
boto3>=1.17.72
+ndg-httpsclient>=0.5.1