summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Madden <jamadden@gmail.com>2022-11-03 15:15:12 -0500
committerJason Madden <jamadden@gmail.com>2022-11-03 15:15:12 -0500
commitf18bff43df80c5190760dc2aedfa436a1fae7bed (patch)
tree375d78b8b6e5a4644d78e36c736a114f8fd54f19
parentfc50ac173d0011492c19c87eb619017fdab47fd9 (diff)
downloadgreenlet-f18bff43df80c5190760dc2aedfa436a1fae7bed.tar.gz
setup.py: Add Python 3.11 to the PyPI classifier metadata.
-rw-r--r--CHANGES.rst7
-rwxr-xr-xmake-manylinux2
-rwxr-xr-xsetup.py3
3 files changed, 7 insertions, 5 deletions
diff --git a/CHANGES.rst b/CHANGES.rst
index 000a5bb..ea4596c 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -2,10 +2,11 @@
Changes
=========
-2.0.1 (unreleased)
-==================
+2.0.0.post0 (unreleased)
+========================
-- Nothing changed yet.
+- Add ``Programming Language :: Python :: 3.11`` to the PyPI
+ classifier metadata.
2.0.0 (2022-10-31)
diff --git a/make-manylinux b/make-manylinux
index f770009..620b348 100755
--- a/make-manylinux
+++ b/make-manylinux
@@ -32,7 +32,7 @@ if [ -d /greenlet -a -d /opt/python ]; then
mkdir -p /greenlet/wheelhouse
OPATH="$PATH"
which auditwheel
- for variant in `ls -d /opt/python/cp{27,35,36,37,38,39,310}*`; do
+ for variant in `ls -d /opt/python/cp{27,35,36,37,38,39,310,311}*`; do
export PATH="$variant/bin:$OPATH"
echo "Building $variant $(python --version)"
diff --git a/setup.py b/setup.py
index a4248af..6c3984c 100755
--- a/setup.py
+++ b/setup.py
@@ -184,7 +184,7 @@ setup(
author="Alexey Borzenkov",
author_email="snaury@gmail.com",
maintainer='Jason Madden',
- maintainer_email='jason@nextthought.com',
+ maintainer_email='jason@seecoresoftware.com',
project_urls={
'Bug Tracker': 'https://github.com/python-greenlet/greenlet/issues',
'Source Code': 'https://github.com/python-greenlet/greenlet/',
@@ -213,6 +213,7 @@ setup(
'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: 3.9',
'Programming Language :: Python :: 3.10',
+ 'Programming Language :: Python :: 3.11',
'Operating System :: OS Independent',
'Topic :: Software Development :: Libraries :: Python Modules'
],