summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Madden <jamadden@gmail.com>2023-01-27 11:25:12 -0600
committerJason Madden <jamadden@gmail.com>2023-01-27 13:39:53 -0600
commitda25c7f3b07e55c2239f3e618cf29dea3c0864e0 (patch)
tree866d0d3e8e8f85e32abacc281a9c4c961b575755
parent424733f52b9d2ad1c0bf8abd58119bc27aec30c8 (diff)
downloadgreenlet-da25c7f3b07e55c2239f3e618cf29dea3c0864e0.tar.gz
Moving to currently supported action versions.
-rw-r--r--.github/workflows/tests.yml48
1 files changed, 16 insertions, 32 deletions
diff --git a/.github/workflows/tests.yml b/.github/workflows/tests.yml
index fa8c4c4..de68d5b 100644
--- a/.github/workflows/tests.yml
+++ b/.github/workflows/tests.yml
@@ -31,18 +31,13 @@ jobs:
# 3.5, 3.6 and presumably 2.7 are not available in it.
os: [ubuntu-20.04, macos-latest]
steps:
- - uses: actions/checkout@v2
+ - uses: actions/checkout@v3
- name: Set up Python
- uses: actions/setup-python@v2
+ uses: actions/setup-python@v4
with:
python-version: ${{ matrix.python-version }}
- - name: Pip cache
- uses: actions/cache@v2
- with:
- path: ~/.cache/pip
- key: ${{ runner.os }}-pip-${{ hashFiles('setup.*') }}
- restore-keys: |
- ${{ runner.os }}-pip-
+ cache: 'pip'
+ cache-dependency-path: setup.py
- name: Install dependencies
run: |
python -m pip install -U pip setuptools wheel
@@ -63,7 +58,7 @@ jobs:
ls -l dist
twine check dist/*
- name: Store greenlet wheel
- uses: actions/upload-artifact@v2
+ uses: actions/upload-artifact@v3
with:
name: greenlet-${{ runner.os }}-${{ matrix.python-version }}.whl
path: dist/*whl
@@ -91,18 +86,13 @@ jobs:
python-version: [2.7, 3.5, "3.11"]
os: [ubuntu-20.04, macos-latest]
steps:
- - uses: actions/checkout@v2
+ - uses: actions/checkout@v3
- name: Set up Python
- uses: actions/setup-python@v2
+ uses: actions/setup-python@v4
with:
python-version: ${{ matrix.python-version }}
- - name: Pip cache
- uses: actions/cache@v2
- with:
- path: ~/.cache/pip
- key: ${{ runner.os }}-pip-ns-${{ hashFiles('setup.*') }}
- restore-keys: |
- ${{ runner.os }}-pip-ns-
+ cache: 'pip'
+ cache-dependency-path: setup.py
- name: Install dependencies
run: |
python -m pip install -U pip setuptools wheel
@@ -124,18 +114,13 @@ jobs:
# required for all workflows
security-events: write
steps:
- - uses: actions/checkout@v2
+ - uses: actions/checkout@v3
- name: Set up Python
- uses: actions/setup-python@v2
+ uses: actions/setup-python@v4
with:
python-version: "3.10"
- - name: Pip cache
- uses: actions/cache@v2
- with:
- path: ~/.cache/pip
- key: ${{ runner.os }}-pip-ql-${{ hashFiles('setup.*') }}
- restore-keys: |
- ${{ runner.os }}-pip-ql-
+ cache: 'pip'
+ cache-dependency-path: setup.py
- name: Install dependencies
run: |
python -m pip install -U pip
@@ -177,12 +162,11 @@ jobs:
steps:
- name: checkout
- uses: actions/checkout@v2
+ uses: actions/checkout@v3
- name: Set up Python ${{ matrix.python-version }}
- uses: actions/setup-python@v2
+ uses: actions/setup-python@v4
with:
python-version: ${{ matrix.python-version }}
-
- name: Enable emulation
run: |
docker run --rm --privileged hypriot/qemu-register
@@ -206,7 +190,7 @@ jobs:
DOCKER_IMAGE: quay.io/pypa/${{ matrix.image }}
run: bash ./make-manylinux
- name: Store greenlet wheels
- uses: actions/upload-artifact@v2
+ uses: actions/upload-artifact@v3
with:
path: wheelhouse/*whl
name: ${{ matrix.image }}_wheels.zip