summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Madden <jamadden@gmail.com>2023-01-26 13:58:25 -0600
committerJason Madden <jamadden@gmail.com>2023-01-26 13:58:25 -0600
commit99cad0de1ee0af3c62d16415d1632d781fa3af60 (patch)
tree38c5aaecf0a694ad13fb29bf5e9c16bd7875f000
parent17a16d631a2e77bbeac48aa3f47712ec8a2460ee (diff)
downloadgreenlet-99cad0de1ee0af3c62d16415d1632d781fa3af60.tar.gz
Fix setup.py encoding; bump github codeql from v2 to v2
-rw-r--r--.github/workflows/tests.yml4
-rwxr-xr-xsetup.py3
2 files changed, 4 insertions, 3 deletions
diff --git a/.github/workflows/tests.yml b/.github/workflows/tests.yml
index 56d986d..fa8c4c4 100644
--- a/.github/workflows/tests.yml
+++ b/.github/workflows/tests.yml
@@ -145,7 +145,7 @@ jobs:
echo "CODEQL_PYTHON=$(which python)" >> $GITHUB_ENV
# Initializes the CodeQL tools for scanning.
- name: Initialize CodeQL
- uses: github/codeql-action/init@v1
+ uses: github/codeql-action/init@v2
with:
languages: python, cpp
# Override the default behavior so that the action doesn't attempt
@@ -157,7 +157,7 @@ jobs:
# - name: Autobuild
# uses: github/codeql-action/autobuild@v1
- name: Perform CodeQL Analysis
- uses: github/codeql-action/analyze@v1
+ uses: github/codeql-action/analyze@v2
manylinux:
diff --git a/setup.py b/setup.py
index fd57725..97278b6 100755
--- a/setup.py
+++ b/setup.py
@@ -1,4 +1,5 @@
#! /usr/bin/env python
+# -*- coding: utf-8 -*-
from __future__ import print_function
import sys
import os
@@ -53,7 +54,7 @@ if (
#
# fails with:
#
- # src/greenlet/platform/switch_riscv_unix.h:30:1: error: s0 cannot be used in ‘asm’ here
+ # src/greenlet/platform/switch_riscv_unix.h:30:1: error: s0 cannot be used in 'asm' here
#
# Adding the -Os flag fixes the problem.
or (is_linux and plat_machine == "riscv64")