summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Madden <jamadden@gmail.com>2021-12-16 13:48:13 -0600
committerJason Madden <jamadden@gmail.com>2021-12-16 13:48:13 -0600
commit250d04b82de6684708ffc5267c5c975b2fc40f30 (patch)
tree4db197539832ceaa65083cdb3f4c5b5171c4a15e
parent2d6e3315d0a97939e8831cba53bb53445841e77e (diff)
downloadgreenlet-codeql.tar.gz
Building like normal failed to find source; try autobuild.codeql
-rw-r--r--.github/workflows/tests.yml38
1 files changed, 20 insertions, 18 deletions
diff --git a/.github/workflows/tests.yml b/.github/workflows/tests.yml
index 7316ffe..aa0403f 100644
--- a/.github/workflows/tests.yml
+++ b/.github/workflows/tests.yml
@@ -126,29 +126,31 @@ jobs:
security-events: write
steps:
- uses: actions/checkout@v2
- - name: Set up Python
- uses: actions/setup-python@v2
- with:
- python-version: "3.10"
- - name: Pip cache
- uses: actions/cache@v2
- with:
- path: ~/.cache/pip
- key: ${{ runner.os }}-pip-ql-${{ hashFiles('setup.*') }}
- restore-keys: |
- ${{ runner.os }}-pip-ql-
+ # - name: Set up Python
+ # uses: actions/setup-python@v2
+ # with:
+ # python-version: "3.10"
+ # - name: Pip cache
+ # uses: actions/cache@v2
+ # with:
+ # path: ~/.cache/pip
+ # key: ${{ runner.os }}-pip-ql-${{ hashFiles('setup.*') }}
+ # restore-keys: |
+ # ${{ runner.os }}-pip-ql-
# Initializes the CodeQL tools for scanning.
- name: Initialize CodeQL
uses: github/codeql-action/init@v1
with:
languages: python, cpp
- - name: Install dependencies
- run: |
- python -m pip install -U pip setuptools wheel
- - name: Install greenlet
- run: |
- python setup.py bdist_wheel
- python -m pip install -U -v -e ".[test,docs]"
+ # - name: Install dependencies
+ # run: |
+ # python -m pip install -U pip setuptools wheel
+ # - name: Install greenlet
+ # run: |
+ # python setup.py bdist_wheel
+ # python -m pip install -U -v -e ".[test,docs]"
+ - name: Autobuild
+ uses: github/codeql-action/autobuild@v1
- name: Perform CodeQL Analysis
uses: github/codeql-action/analyze@v1