summaryrefslogtreecommitdiff
path: root/test-requirements.txt
diff options
context:
space:
mode:
authorAntoine Musso <hashar@free.fr>2014-07-25 11:01:30 +0200
committerAntoine Musso <hashar@free.fr>2014-07-25 11:20:27 +0200
commit2ddd5e5ef89da7f1e3b3a7d081fbc7f5c46ac11c (patch)
tree82dbc96c2b43f6e188a256b05cc395d99765e165 /test-requirements.txt
parentdbd784b870a878ef6dbecd14310018cdaeda5c6d (diff)
downloadgitpython-2ddd5e5ef89da7f1e3b3a7d081fbc7f5c46ac11c.tar.gz
Use tox to easily run tests in venv
tox https://pypi.python.org/pypi/tox is a thin wrapper around virtualenv which let you craft a fresh python environement to execute command in. It creates the env with virtualenv, install dependencies, run python setup.py install in it and then execute whatever command you want it to do and report status. To do so I simply: - listed tests dependencies in test-requirements.txt (which are just nose and mock) - provide a tox.ini file which describe how to install the dependencies and execute nosetests - added the module 'coverage' to the list of test dependencies To run tests simply: pip install tox && tox That will execute the test command 'nosetests' using python2.6 and then python 2.7. The additional env 'cover' can be run using: tox -ecover.
Diffstat (limited to 'test-requirements.txt')
-rw-r--r--test-requirements.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/test-requirements.txt b/test-requirements.txt
new file mode 100644
index 00000000..6da60814
--- /dev/null
+++ b/test-requirements.txt
@@ -0,0 +1,4 @@
+# Remember to update README.md
+coverage
+nose
+mock