summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorSebastian Thiel <sebastian.thiel@icloud.com>2020-07-12 18:04:26 +0800
committerSebastian Thiel <sebastian.thiel@icloud.com>2020-07-12 18:04:26 +0800
commitd5f0d48745727684473cf583a002e2c31174de2d (patch)
tree2c499fe4cb719e8b95d74449363bc20cf280bcce /setup.py
parentfe65adc904f3e3ebf74e983e91b4346d5bacc468 (diff)
downloadgitpython-d5f0d48745727684473cf583a002e2c31174de2d.tar.gz
Revert moving tests out of 'git' folder, related to #1030
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 54e43bea..11a1d6b7 100755
--- a/setup.py
+++ b/setup.py
@@ -74,9 +74,9 @@ setup(
author="Sebastian Thiel, Michael Trier",
author_email="byronimo@gmail.com, mtrier@gmail.com",
url="https://github.com/gitpython-developers/GitPython",
- packages=find_packages(exclude=("test.*")),
- include_package_data=True,
+ packages=find_packages('.'),
py_modules=['git.' + f[:-3] for f in os.listdir('./git') if f.endswith('.py')],
+ package_data={'git.test': ['fixtures/*']},
package_dir={'git': 'git'},
python_requires='>=3.4',
install_requires=requirements,