summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorSebastian Thiel <byronimo@gmail.com>2014-11-14 15:52:17 +0100
committerSebastian Thiel <byronimo@gmail.com>2014-11-14 15:52:34 +0100
commitc5452aa820c0f5c2454642587ff6a3bd6d96eaa1 (patch)
tree6fa7bb77459dbb368a72361f237ca18118d0e2a9 /setup.py
parentd3e5d9cda8eae5b0f19ac25efada6d0b3b9e04e5 (diff)
downloadgitpython-c5452aa820c0f5c2454642587ff6a3bd6d96eaa1.tar.gz
Prepared release 0.3.20.3.2
It represents the latest state on github, which should be better than what's installed by default. [skip ci]
Diffstat (limited to 'setup.py')
-rwxr-xr-x[-rw-r--r--]setup.py28
1 files changed, 23 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index e7c927b1..ed04a581 100644..100755
--- a/setup.py
+++ b/setup.py
@@ -61,6 +61,7 @@ def _stamp_version(filename):
else:
print >> sys.stderr, "WARNING: Couldn't find version line in file %s" % filename
+install_requires = ('gitdb >= 0.6.0',)
setup(name = "GitPython",
cmdclass={'build_py': build_py, 'sdist': sdist},
version = VERSION,
@@ -73,18 +74,35 @@ setup(name = "GitPython",
package_data = {'git.test' : ['fixtures/*']},
package_dir = {'git':'git'},
license = "BSD License",
- install_requires='gitdb >= 0.5.1',
+ requires=('gitdb (>=0.6.0)', ),
+ install_requires=install_requires,
+ test_requirements = ('mock', 'nose') + install_requires,
zip_safe=False,
long_description = """\
GitPython is a python library used to interact with Git repositories""",
- classifiers = [
+ classifiers=[
+ # Picked from
+ # http://pypi.python.org/pypi?:action=list_classifiers
+ #"Development Status :: 1 - Planning",
+ #"Development Status :: 2 - Pre-Alpha",
+ #"Development Status :: 3 - Alpha",
"Development Status :: 4 - Beta",
+ # "Development Status :: 5 - Production/Stable",
+ #"Development Status :: 6 - Mature",
+ #"Development Status :: 7 - Inactive",
+ "Environment :: Console",
"Intended Audience :: Developers",
"License :: OSI Approved :: BSD License",
"Operating System :: OS Independent",
+ "Operating System :: POSIX",
+ "Operating System :: Microsoft :: Windows",
+ "Operating System :: MacOS :: MacOS X",
"Programming Language :: Python",
- "Programming Language :: Python :: 2.5",
+ "Programming Language :: Python :: 2",
"Programming Language :: Python :: 2.6",
- "Topic :: Software Development :: Libraries :: Python Modules",
- ]
+ "Programming Language :: Python :: 2.7",
+ # "Programming Language :: Python :: 3",
+ # "Programming Language :: Python :: 3.3",
+ # "Programming Language :: Python :: 3.4",
+ ]
)