summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorHugo <hugovk@users.noreply.github.com>2018-03-18 12:06:10 +0200
committerHugo <hugovk@users.noreply.github.com>2018-03-18 22:26:04 +0200
commit929f3e1e1b664ed8cdef90a40c96804edfd08d59 (patch)
tree805c06bde21a6c4b3d9defe775527a3773bef3b9 /setup.py
parent190c04569bd2a29597065222cdcc322ec4f2b374 (diff)
downloadgitpython-929f3e1e1b664ed8cdef90a40c96804edfd08d59.tar.gz
Drop support for EOL Python 2.6
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py24
1 files changed, 1 insertions, 23 deletions
diff --git a/setup.py b/setup.py
index 47523e03..e0641824 100755
--- a/setup.py
+++ b/setup.py
@@ -9,8 +9,6 @@ except ImportError:
from distutils.command.build_py import build_py as _build_py
from setuptools.command.sdist import sdist as _sdist
-import pkg_resources
-import logging
import os
import sys
from os import path
@@ -66,26 +64,7 @@ def _stamp_version(filename):
install_requires = ['gitdb2 >= 2.0.0']
-extras_require = {
- ':python_version == "2.6"': ['ordereddict'],
-}
test_requires = ['ddt>=1.1.1']
-if sys.version_info[:2] < (2, 7):
- test_requires.append('mock')
-
-try:
- if 'bdist_wheel' not in sys.argv:
- for key, value in extras_require.items():
- if key.startswith(':') and pkg_resources.evaluate_marker(key[1:]):
- install_requires.extend(value)
-except Exception:
- logging.getLogger(__name__).exception(
- 'Something went wrong calculating platform specific dependencies, so '
- "you're getting them all!"
- )
- for key, value in extras_require.items():
- if key.startswith(':'):
- install_requires.extend(value)
# end
setup(
@@ -101,7 +80,7 @@ setup(
package_data={'git.test': ['fixtures/*']},
package_dir={'git': 'git'},
license="BSD License",
- python_requires='>=2.6, !=3.0.*, !=3.1.*, !=3.2.*',
+ python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*',
requires=['gitdb2 (>=2.0.0)'],
install_requires=install_requires,
test_requirements=test_requires + install_requires,
@@ -126,7 +105,6 @@ setup(
"Operating System :: MacOS :: MacOS X",
"Programming Language :: Python",
"Programming Language :: Python :: 2",
- "Programming Language :: Python :: 2.6",
"Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3",
"Programming Language :: Python :: 3.3",