summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorSebastian Thiel <sthiel@thoughtworks.com>2019-07-29 07:57:46 +0800
committerSebastian Thiel <sthiel@thoughtworks.com>2019-07-29 07:57:46 +0800
commit913d806f02cf50250d230f88b897350581f80f6b (patch)
tree734deb5048687341e64f68b4162af81c829458bf /setup.py
parentce7e1507fa5f6faf049794d4d47b14157d1f2e50 (diff)
downloadgitpython-913d806f02cf50250d230f88b897350581f80f6b.tar.gz
Revert "Drop python 2.7 support and help with encodings"
This reverts commit dac619e4917b0ad43d836a534633d68a871aecca.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 65656d55..49288f69 100755
--- a/setup.py
+++ b/setup.py
@@ -79,7 +79,7 @@ setup(
package_data={'git.test': ['fixtures/*']},
package_dir={'git': 'git'},
license="BSD License",
- python_requires='>=3.0, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*',
+ python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*',
install_requires=requirements,
tests_require=requirements + test_requirements,
zip_safe=False,
@@ -102,6 +102,8 @@ setup(
"Operating System :: Microsoft :: Windows",
"Operating System :: MacOS :: MacOS X",
"Programming Language :: Python",
+ "Programming Language :: Python :: 2",
+ "Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3",
"Programming Language :: Python :: 3.4",
"Programming Language :: Python :: 3.5",