summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorSebastian Thiel <byronimo@gmail.com>2010-11-21 20:01:47 +0100
committerSebastian Thiel <byronimo@gmail.com>2010-11-21 20:01:47 +0100
commit83a9e4a0dad595188ff3fb35bc3dfc4d931eff6d (patch)
tree999bb5875c1714e7dcd38c7b4353b9a4362409fd /setup.py
parente6019e16d5a74dc49eb7129ee7fd78b4de51dac2 (diff)
downloadgitpython-83a9e4a0dad595188ff3fb35bc3dfc4d931eff6d.tar.gz
Fixed setup script to work with changed folder structure
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py118
1 files changed, 62 insertions, 56 deletions
diff --git a/setup.py b/setup.py
index 2d2fb690..b4cdb15f 100755
--- a/setup.py
+++ b/setup.py
@@ -1,10 +1,10 @@
#!/usr/bin/env python
try:
- from setuptools import setup, find_packages
+ from setuptools import setup, find_packages
except ImportError:
- from ez_setup import use_setuptools
- use_setuptools()
- from setuptools import setup, find_packages
+ from ez_setup import use_setuptools
+ use_setuptools()
+ from setuptools import setup, find_packages
from distutils.command.build_py import build_py as _build_py
from setuptools.command.sdist import sdist as _sdist
@@ -15,65 +15,71 @@ v = open(path.join(path.dirname(__file__), 'VERSION'))
VERSION = v.readline().strip()
v.close()
+
class build_py(_build_py):
- def run(self):
- init = path.join(self.build_lib, 'git', '__init__.py')
- if path.exists(init):
- os.unlink(init)
- _build_py.run(self)
- _stamp_version(init)
- self.byte_compile([init])
+ def run(self):
+ init = path.join(self.build_lib, 'git', '__init__.py')
+ if path.exists(init):
+ os.unlink(init)
+ _build_py.run(self)
+ _stamp_version(init)
+ self.byte_compile([init])
+
class sdist(_sdist):
- def make_release_tree (self, base_dir, files):
- _sdist.make_release_tree(self, base_dir, files)
- orig = path.join('lib', 'git', '__init__.py')
- assert path.exists(orig)
- dest = path.join(base_dir, orig)
- if hasattr(os, 'link') and path.exists(dest):
- os.unlink(dest)
- self.copy_file(orig, dest)
- _stamp_version(dest)
+ def make_release_tree (self, base_dir, files):
+ _sdist.make_release_tree(self, base_dir, files)
+ orig = '__init__.py'
+ assert path.exists(orig)
+ dest = path.join(base_dir, orig)
+ if hasattr(os, 'link') and path.exists(dest):
+ os.unlink(dest)
+ self.copy_file(orig, dest)
+ _stamp_version(dest)
+
def _stamp_version(filename):
- found, out = False, []
- f = open(filename, 'r')
- for line in f:
- if '__version__ =' in line:
- line = line.replace("'git'", "'%s'" % VERSION)
- found = True
- out.append(line)
- f.close()
+ found, out = False, []
+ f = open(filename, 'r')
+ for line in f:
+ if '__version__ =' in line:
+ line = line.replace("'git'", "'%s'" % VERSION)
+ found = True
+ out.append(line)
+ f.close()
- if found:
- f = open(filename, 'w')
- f.writelines(out)
- f.close()
+ if found:
+ f = open(filename, 'w')
+ f.writelines(out)
+ f.close()
+ else:
+ print >> sys.stderr, "WARNING: Couldn't find version line in file %s" % filename
setup(name = "GitPython",
- cmdclass={'build_py': build_py, 'sdist': sdist},
- version = VERSION,
- description = "Python Git Library",
- author = "Sebastian Thiel, Michael Trier",
- author_email = "byronimo@gmail.com, mtrier@gmail.com",
- url = "http://gitorious.org/projects/git-python/",
- packages = find_packages('lib'),
- package_dir = {'':'lib'},
- license = "BSD License",
- requires=('gitdb (>=0.5.1)',),
- install_requires='gitdb >= 0.5.1',
- zip_safe=False,
- long_description = """\
+ cmdclass={'build_py': build_py, 'sdist': sdist},
+ version = VERSION,
+ description = "Python Git Library",
+ author = "Sebastian Thiel, Michael Trier",
+ author_email = "byronimo@gmail.com, mtrier@gmail.com",
+ url = "http://gitorious.org/projects/git-python/",
+ packages = ['git.'+p for p in find_packages('.')],
+ py_modules = ['git.'+f[:-3] for f in os.listdir('.') if f.endswith('.py')],
+ package_dir = {'git':''},
+ license = "BSD License",
+ requires=('gitdb (>=0.5.1)',),
+ install_requires='gitdb >= 0.5.1',
+ zip_safe=False,
+ long_description = """\
GitPython is a python library used to interact with Git repositories""",
- classifiers = [
- "Development Status :: 4 - Beta",
- "Intended Audience :: Developers",
- "License :: OSI Approved :: BSD License",
- "Operating System :: OS Independent",
- "Programming Language :: Python",
- "Programming Language :: Python :: 2.5",
- "Programming Language :: Python :: 2.6",
- "Topic :: Software Development :: Libraries :: Python Modules",
- ]
- )
+ classifiers = [
+ "Development Status :: 4 - Beta",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: BSD License",
+ "Operating System :: OS Independent",
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 2.5",
+ "Programming Language :: Python :: 2.6",
+ "Topic :: Software Development :: Libraries :: Python Modules",
+ ]
+ )