summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorYobmod <yobmod@gmail.com>2021-07-19 17:03:50 +0100
committerYobmod <yobmod@gmail.com>2021-07-19 17:03:50 +0100
commit795d2b1f75c6c210ebabd81f33c0c9ac8b57729e (patch)
treef79aefd6f1d4bb8a5a0e750fe7aa8e5fdfc3f1df /setup.py
parent454576254b873b7ebc45bb30846e5831dc2d8817 (diff)
downloadgitpython-795d2b1f75c6c210ebabd81f33c0c9ac8b57729e.tar.gz
rmv redundant IOerror except
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index e01562e8..e8da06dc 100755
--- a/setup.py
+++ b/setup.py
@@ -56,7 +56,7 @@ def _stamp_version(filename):
line = line.replace("'git'", "'%s'" % VERSION)
found = True
out.append(line)
- except (IOError, OSError):
+ except OSError:
print("Couldn't find file %s to stamp version" % filename, file=sys.stderr)
if found:
@@ -66,7 +66,7 @@ def _stamp_version(filename):
print("WARNING: Couldn't find version line in file %s" % filename, file=sys.stderr)
-def build_py_modules(basedir, excludes=[]):
+def build_py_modules(basedir, excludes=()):
# create list of py_modules from tree
res = set()
_prefix = os.path.basename(basedir)