summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorKostis Anagnostopoulos <ankostis@gmail.com>2016-09-15 00:59:36 +0200
committerKostis Anagnostopoulos <ankostis@gmail.com>2016-09-25 18:35:03 +0200
commit7842e92ebaf3fc3380cc8d704afa3841f333748c (patch)
tree0e5b1cdba78bce1c6f26c41945d267a715501d58 /setup.py
parentf73468bb9cb9e479a0b81e3766623c32802db579 (diff)
downloadgitpython-7842e92ebaf3fc3380cc8d704afa3841f333748c.tar.gz
test, deps: FIX `mock` deps on py3.
+ Del extra spaces, import os.path as osp
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 05c12b8f..b3b43eb3 100755
--- a/setup.py
+++ b/setup.py
@@ -68,8 +68,10 @@ def _stamp_version(filename):
print("WARNING: Couldn't find version line in file %s" % filename, file=sys.stderr)
install_requires = ['gitdb >= 0.6.4']
+test_requires = ['node']
if sys.version_info[:2] < (2, 7):
install_requires.append('ordereddict')
+ test_requires.append('mock')
# end
setup(
@@ -87,7 +89,7 @@ setup(
license="BSD License",
requires=['gitdb (>=0.6.4)'],
install_requires=install_requires,
- test_requirements=['mock', 'nose'] + install_requires,
+ test_requirements=test_requires + install_requires,
zip_safe=False,
long_description="""\
GitPython is a python library used to interact with Git repositories""",