summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorSebastian Thiel <byronimo@gmail.com>2011-01-17 23:15:14 +0100
committerSebastian Thiel <byronimo@gmail.com>2011-01-17 23:15:14 +0100
commit5eb7fd3f0dd99dc6c49da6fd7e78a392c4ef1b33 (patch)
tree4f9bf188ec54e9af547660f57ea3084819fc66de /setup.py
parent031271e890327f631068571a3f79235a35a4f73e (diff)
downloadgitpython-5eb7fd3f0dd99dc6c49da6fd7e78a392c4ef1b33.tar.gz
setup.py: fixed incorrect handling of toplevel package path - I must have been very confused when setting it up that way0.3.1-beta2
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py9
1 files changed, 4 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index c18d80b5..1c58cb65 100755
--- a/setup.py
+++ b/setup.py
@@ -40,7 +40,7 @@ class sdist(_sdist):
def _stamp_version(filename):
- found, out = False, []
+ found, out = False, list()
try:
f = open(filename, 'r')
except (IOError, OSError):
@@ -61,7 +61,6 @@ def _stamp_version(filename):
else:
print >> sys.stderr, "WARNING: Couldn't find version line in file %s" % filename
-
setup(name = "GitPython",
cmdclass={'build_py': build_py, 'sdist': sdist},
version = VERSION,
@@ -69,10 +68,10 @@ setup(name = "GitPython",
author = "Sebastian Thiel, Michael Trier",
author_email = "byronimo@gmail.com, mtrier@gmail.com",
url = "http://gitorious.org/projects/git-python/",
- packages = ['git.'+p for p in find_packages('.')],
- py_modules = ['git.'+f[:-3] for f in os.listdir('.') if f.endswith('.py')],
+ packages = find_packages('.'),
+ py_modules = ['git.'+f[:-3] for f in os.listdir('./git') if f.endswith('.py')],
package_data = {'git.test' : ['fixtures/*']},
- package_dir = {'git':''},
+ package_dir = {'git':'git'},
license = "BSD License",
requires=('gitdb (>=0.5.1)',),
install_requires='gitdb >= 0.5.1',