summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDominic <yobmod@gmail.com>2021-09-09 20:01:57 +0100
committerGitHub <noreply@github.com>2021-09-09 20:01:57 +0100
commit58820a5e1481e3d3907eda24422f635893342047 (patch)
tree0892a99c15765ea0c591c794c947c2cbf50f5f3e /setup.py
parente488ce376d7bb92d3d9bb1c6d2408f1ec2a2d5f4 (diff)
downloadgitpython-58820a5e1481e3d3907eda24422f635893342047.tar.gz
Update setup.py
format path -> os.path in prep for pathlib
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py15
1 files changed, 7 insertions, 8 deletions
diff --git a/setup.py b/setup.py
index 2425c3f1..11696e75 100755
--- a/setup.py
+++ b/setup.py
@@ -5,9 +5,8 @@ from setuptools.command.sdist import sdist as _sdist
import fnmatch
import os
import sys
-from os import path
-with open(path.join(path.dirname(__file__), 'VERSION')) as v:
+with open(os.path.join(os.path.dirname(__file__), 'VERSION')) as v:
VERSION = v.readline().strip()
with open('requirements.txt') as reqs_file:
@@ -22,8 +21,8 @@ with open('README.md') as rm_file:
class build_py(_build_py):
def run(self) -> None:
- init = path.join(self.build_lib, 'git', '__init__.py')
- if path.exists(init):
+ init = os.path.join(self.build_lib, 'git', '__init__.py')
+ if os.path.exists(init):
os.unlink(init)
_build_py.run(self)
_stamp_version(init)
@@ -34,10 +33,10 @@ class sdist(_sdist):
def make_release_tree(self, base_dir: str, files: Sequence) -> None:
_sdist.make_release_tree(self, base_dir, files)
- orig = path.join('git', '__init__.py')
- assert path.exists(orig), orig
- dest = path.join(base_dir, orig)
- if hasattr(os, 'link') and path.exists(dest):
+ orig = os.path.join('git', '__init__.py')
+ assert os.path.exists(orig), orig
+ dest = os.path.join(base_dir, orig)
+ if hasattr(os, 'link') and os.path.exists(dest):
os.unlink(dest)
self.copy_file(orig, dest)
_stamp_version(dest)