summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorKostis Anagnostopoulos <ankostis@gmail.com>2016-09-27 23:57:53 +0200
committerKostis Anagnostopoulos <ankostis@gmail.com>2016-09-28 03:35:38 +0200
commit467416356a96148bcb01feb771f6ea20e5215727 (patch)
treeb76b72a024eb285524fc8e846a7ab22aeb243ee4 /setup.py
parent57550cce417340abcc25b20b83706788328f79bd (diff)
downloadgitpython-467416356a96148bcb01feb771f6ea20e5215727.tar.gz
test: Start using `ddt` library for TCs
+ DataDriven TCs for identifying which separate case failed. + appveyor: rework matrix, conda3.4 cannot install in develop mode
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index b3b43eb3..2e8ee520 100755
--- a/setup.py
+++ b/setup.py
@@ -68,7 +68,7 @@ def _stamp_version(filename):
print("WARNING: Couldn't find version line in file %s" % filename, file=sys.stderr)
install_requires = ['gitdb >= 0.6.4']
-test_requires = ['node']
+test_requires = ['node', 'ddt']
if sys.version_info[:2] < (2, 7):
install_requires.append('ordereddict')
test_requires.append('mock')