summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorYobmod <yobmod@gmail.com>2021-02-24 16:47:40 +0000
committerYobmod <yobmod@gmail.com>2021-02-24 16:47:40 +0000
commit2f8320b7bf75b6ec375ade605a9812b4b2147de9 (patch)
treea0403feef4f2ccbe7a7fef5bb88d007b589145fc /setup.py
parentb3778ec37d17a6eb781fa9c6b5e2009fa7542d77 (diff)
downloadgitpython-2f8320b7bf75b6ec375ade605a9812b4b2147de9.tar.gz
drop python 3.4, update .gitignore
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index ef9dd33d..652cbd17 100755
--- a/setup.py
+++ b/setup.py
@@ -98,7 +98,7 @@ setup(
include_package_data=True,
py_modules=build_py_modules("./git", excludes=["git.ext.*"]),
package_dir={'git': 'git'},
- python_requires='>=3.4',
+ python_requires='>=3.5',
install_requires=requirements,
tests_require=requirements + test_requirements,
zip_safe=False,
@@ -122,10 +122,10 @@ setup(
"Operating System :: MacOS :: MacOS X",
"Programming Language :: Python",
"Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.4",
"Programming Language :: Python :: 3.5",
"Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
- "Programming Language :: Python :: 3.8"
+ "Programming Language :: Python :: 3.8",
+
]
)