summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authoryobmod <yobmod@gmail.com>2021-02-28 17:52:45 +0000
committeryobmod <yobmod@gmail.com>2021-02-28 17:52:45 +0000
commit1f2f3e848e10d145fe28d6a8e07b0c579dd0c276 (patch)
tree98a6c4499fb3346f92eba2e1dddf31338601565f /setup.py
parent803aca26d3f611f7dfd7148f093f525578d609ef (diff)
downloadgitpython-1f2f3e848e10d145fe28d6a8e07b0c579dd0c276.tar.gz
drop py3.4 support
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 1 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 500e88c8..2acb4076 100755
--- a/setup.py
+++ b/setup.py
@@ -98,7 +98,7 @@ setup(
include_package_data=True,
py_modules=build_py_modules("./git", excludes=["git.ext.*"]),
package_dir={'git': 'git'},
- python_requires='>=3.4',
+ python_requires='>=3.5',
install_requires=requirements,
tests_require=requirements + test_requirements,
zip_safe=False,
@@ -122,7 +122,6 @@ setup(
"Operating System :: MacOS :: MacOS X",
"Programming Language :: Python",
"Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.4",
"Programming Language :: Python :: 3.5",
"Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",