summaryrefslogtreecommitdiff
path: root/git
diff options
context:
space:
mode:
authorJames E. King III <jking@apache.org>2019-01-15 16:16:33 -0500
committerSebastian Thiel <byronimo@gmail.com>2019-05-05 13:22:53 +0530
commitce21f63f7acba9b82cea22790c773e539a39c158 (patch)
tree8c63814a486cee0a66ee092aad90cc3997b1dfd2 /git
parent1f66e25c25cde2423917ee18c4704fff83b837d1 (diff)
downloadgitpython-ce21f63f7acba9b82cea22790c773e539a39c158.tar.gz
Fix setup.py and use of requirements files.
Diffstat (limited to 'git')
-rw-r--r--git/cmd.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/git/cmd.py b/git/cmd.py
index a4faefe2..1b24a626 100644
--- a/git/cmd.py
+++ b/git/cmd.py
@@ -220,7 +220,8 @@ class Git(LazyMixin):
# - a GitCommandNotFound error is spawned by ourselves
# - a PermissionError is spawned if the git executable provided
# cannot be executed for whatever reason
- exceptions = (GitCommandNotFound, PermissionError)
+ exceptions = (GitCommandNotFound, PermissionError) # noqa
+ # (silence erroneous flake8 F821)
has_git = False
try: