summaryrefslogtreecommitdiff
path: root/README.md
diff options
context:
space:
mode:
authorDominic <yobmod@gmail.com>2021-07-19 14:53:39 +0100
committerGitHub <noreply@github.com>2021-07-19 14:53:39 +0100
commitf587b21a98e7c26986db87d991af42cafcfebb07 (patch)
treec7e162bb6962be9f33b9f7edb84da1b7511fe0d7 /README.md
parent9f906b36533f041df80e2bdf3e40a644574f20ff (diff)
downloadgitpython-f587b21a98e7c26986db87d991af42cafcfebb07.tar.gz
Update README.md
Update testing section
Diffstat (limited to 'README.md')
-rw-r--r--README.md16
1 files changed, 9 insertions, 7 deletions
diff --git a/README.md b/README.md
index 0f7ac5ea..ad7aae51 100644
--- a/README.md
+++ b/README.md
@@ -106,18 +106,20 @@ On *Windows*, make sure you have `git-daemon` in your PATH. For MINGW-git, the
exists in `Git\mingw64\libexec\git-core\`; CYGWIN has no daemon, but should get along fine
with MINGW's.
-The easiest way to run tests is by using [tox](https://pypi.python.org/pypi/tox)
-a wrapper around virtualenv. It will take care of setting up environments with the proper
-dependencies installed and execute test commands. To install it simply:
+Ensure testing libraries are installed. In the root directory, run: `pip install test-requirements.txt`
+Then,
- pip install tox
+To lint, run `flake8`
+To typecheck, run `mypy -p git`
+To test, `pytest`
-Then run:
+Configuration for flake8 is in root/.flake8 file.
+Configuration for mypy, pytest, coverage is in root/pyproject.toml.
- tox
+The same linting and testing will also be performed against different supported python versions
+upon submitting a pull request (or on each push if you have a fork with a "main" branch).
-For more fine-grained control, you can use `unittest`.
### Contributions