summaryrefslogtreecommitdiff
path: root/README.md
diff options
context:
space:
mode:
authorDominic <yobmod@gmail.com>2021-07-19 17:11:57 +0100
committerGitHub <noreply@github.com>2021-07-19 17:11:57 +0100
commitf0bc672b6056778e358c8f5844b093d2742d00ab (patch)
tree47910138f8715967dbe6aea16801a21e00d83056 /README.md
parent9a587e14d509cc77bf47b9591d1def3e5a1df570 (diff)
downloadgitpython-f0bc672b6056778e358c8f5844b093d2742d00ab.tar.gz
Update README.md
tidy up testing section
Diffstat (limited to 'README.md')
-rw-r--r--README.md19
1 files changed, 10 insertions, 9 deletions
diff --git a/README.md b/README.md
index ad7aae51..2cd68d69 100644
--- a/README.md
+++ b/README.md
@@ -106,19 +106,20 @@ On *Windows*, make sure you have `git-daemon` in your PATH. For MINGW-git, the
exists in `Git\mingw64\libexec\git-core\`; CYGWIN has no daemon, but should get along fine
with MINGW's.
-Ensure testing libraries are installed. In the root directory, run: `pip install test-requirements.txt`
-Then,
+Ensure testing libraries are installed.
+In the root directory, run: `pip install -r test-requirements.txt`
-To lint, run `flake8`
-To typecheck, run `mypy -p git`
-To test, `pytest`
+To lint, run: `flake8`
-Configuration for flake8 is in root/.flake8 file.
-Configuration for mypy, pytest, coverage is in root/pyproject.toml.
+To typecheck, run: `mypy -p git`
-The same linting and testing will also be performed against different supported python versions
-upon submitting a pull request (or on each push if you have a fork with a "main" branch).
+To test, run: `pytest`
+
+Configuration for flake8 is in the root/.flake8 file.
+Configurations for mypy, pytest and coverage.py are in root/pyproject.toml.
+The same linting and testing will also be performed against different supported python versions
+upon submitting a pull request (or on each push if you have a fork with a "main" branch and actions enabled).
### Contributions