summaryrefslogtreecommitdiff
path: root/README.md
diff options
context:
space:
mode:
authorSebastian Thiel <byronimo@gmail.com>2016-04-24 09:37:15 +0200
committerSebastian Thiel <byronimo@gmail.com>2016-04-24 09:37:15 +0200
commit9149c34a8b99052b4e92289c035a3c2d04fb8246 (patch)
treef3ebdea1edd9c8dee2a84e2d0bec910ce73bbe50 /README.md
parent9c9497463b130cce1de1b5d0b6faada330ecdc96 (diff)
downloadgitpython-9149c34a8b99052b4e92289c035a3c2d04fb8246.tar.gz
Information on how to make a release on pypi
Diffstat (limited to 'README.md')
-rw-r--r--README.md27
1 files changed, 27 insertions, 0 deletions
diff --git a/README.md b/README.md
index 4865c70a..a0638028 100644
--- a/README.md
+++ b/README.md
@@ -68,6 +68,33 @@ You can watch me fix issues or implement new features [live on Twitch][twitch-ch
* The encountered stack-trace, if applicable
* Enough information to allow reproducing the issue
+### How to make a new release
+
+* assure `changes.rst` is up-to-date
+* put new version into `VERSION` file
+* run `./setup.py sdist`
+* On https://pypi.python.org
+ - Click `GitPython` (and pray it will not timeout)
+ - Lucky ? Click `edit` on the last version, and copy the main description text
+ to your clipboard - it's needed later.
+ - On top of that page, click the `PKG file` button or drag & drop the one from
+ `./GitPython.egg-info/PKG-INFO` on it. Then click the `add ...` button to
+ create a new version.
+ - Paste the previously copied description text into the description field, and click the `add information` button on the very bottom of the page.
+ - Click `GitPython` again and then click `files` of the newly created version.
+ - Select `source package` in the dropdown, then choose or drag & drop
+ `./dist/GitPython-<version>.tar.gz` onto the file path.
+ - Click the `upload` button.
+* Run `git tag <version>` to mark the version you just uploaded to pypi.
+* Run `git push --tags origin master` to publish the changes.
+* finally, set the upcoming version in the `VERSION` file, usually be incrementing
+ the patch level, and possibly by appending `-dev`. Probably you want to `git push` once more.
+
+*NOTE:* At the time of writing, pypi wouldn't hear my prayers and did timeout on
+me, which is why button names are just *guesses*. It's advised to update this text
+next time someone manages to publish a new release to a system so firmly rooted in
+the past.
+
### LICENSE
New BSD License. See the LICENSE file.