summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJames E. King III <jking@apache.org>2019-02-05 13:40:12 -0500
committerSebastian Thiel <byronimo@gmail.com>2019-05-05 13:22:53 +0530
commit52ee33ac9b234c7501d97b4c2bf2e2035c5ec1fa (patch)
tree284d5f9db4f88e8d4e9c3ce7aa52d22714e73ff8 /Makefile
parent14b221bf98757ba61977c1021722eb2faec1d7cc (diff)
downloadgitpython-52ee33ac9b234c7501d97b4c2bf2e2035c5ec1fa.tar.gz
Added a Dockerfile that creates a clean Ubuntu Xenial test environment
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 764b822b..ae74a0d8 100644
--- a/Makefile
+++ b/Makefile
@@ -1,3 +1,5 @@
+.PHONY: all clean release force_release docker-build test nose-pdb
+
all:
@grep -Ee '^[a-z].*:' Makefile | cut -d: -f1 | grep -vF all
@@ -16,3 +18,17 @@ force_release: clean
git push --tags origin master
python3 setup.py sdist bdist_wheel
twine upload -s -i byronimo@gmail.com dist/*
+
+docker-build:
+ docker build --quiet -t gitpython:xenial -f Dockerfile .
+
+test: docker-build
+ # NOTE!!!
+ # NOTE!!! If you are not running from master or have local changes then tests will fail
+ # NOTE!!!
+ docker run --rm -v ${CURDIR}:/src -w /src -t gitpython:xenial tox
+
+nose-pdb: docker-build
+ # run tests under nose and break on error or failure into python debugger
+ # HINT: set PYVER to "pyXX" to change from the default of py37 to pyXX for nose tests
+ docker run --rm --env PYVER=${PYVER} -v ${CURDIR}:/src -w /src -it gitpython:xenial /bin/bash dockernose.sh