summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Käufl <michael-k@users.noreply.github.com>2018-09-10 19:51:32 +0200
committerSebastian Thiel <byronimo@gmail.com>2018-10-21 12:24:21 +0200
commit8fc6563219017354bdfbc1bf62ec3a43ad6febcb (patch)
tree100f8b6bb47aa6f1cb934157fe1cc41b2a0e305a
parenta1634dc48b39ecca11dc39fd8bbf9f1d8f1b7be6 (diff)
downloadgitpython-8fc6563219017354bdfbc1bf62ec3a43ad6febcb.tar.gz
Document support for Python 3.7
-rw-r--r--.travis.yml8
-rw-r--r--README.md2
-rwxr-xr-xsetup.py1
-rw-r--r--tox.ini2
4 files changed, 7 insertions, 6 deletions
diff --git a/.travis.yml b/.travis.yml
index 52223bdb..79e314b8 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -4,14 +4,14 @@ python:
- "3.4"
- "3.5"
- "3.6"
- - "3.6-dev"
- - "3.7-dev"
- "nightly"
# - "pypy" - won't work as smmap doesn't work (see gitdb/.travis.yml for details)
matrix:
+ include:
+ - python: 3.7
+ dist: xenial
+ sudo: required
allow_failures:
- - python: "3.6-dev"
- - python: "3.7-dev"
- python: "nightly"
git:
# a higher depth is needed for most of the tests - must be high enough to not actually be shallow
diff --git a/README.md b/README.md
index 5313f91f..be7b32d1 100644
--- a/README.md
+++ b/README.md
@@ -19,7 +19,7 @@ If it is not in your `PATH`, you can help GitPython find it by setting
the `GIT_PYTHON_GIT_EXECUTABLE=<path/to/git>` environment variable.
* Git (1.7.x or newer)
-* Python 2.7 to 3.6.
+* Python 2.7 to 3.7.
The list of dependencies are listed in `./requirements.txt` and `./test-requirements.txt`.
The installer takes care of installing them for you.
diff --git a/setup.py b/setup.py
index 2703a9ca..cb0300f7 100755
--- a/setup.py
+++ b/setup.py
@@ -110,5 +110,6 @@ setup(
"Programming Language :: Python :: 3.4",
"Programming Language :: Python :: 3.5",
"Programming Language :: Python :: 3.6",
+ "Programming Language :: Python :: 3.7",
]
)
diff --git a/tox.ini b/tox.ini
index ed09c08b..eb2fe834 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py27,py34,py35,py36,flake8
+envlist = py27,py34,py35,py36,py37,flake8
[testenv]
commands = nosetests {posargs}