summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Thiel <byronimo@gmail.com>2014-11-14 15:52:17 +0100
committerSebastian Thiel <byronimo@gmail.com>2014-11-14 15:52:34 +0100
commitc5452aa820c0f5c2454642587ff6a3bd6d96eaa1 (patch)
tree6fa7bb77459dbb368a72361f237ca18118d0e2a9
parentd3e5d9cda8eae5b0f19ac25efada6d0b3b9e04e5 (diff)
downloadgitpython-0.3.2.tar.gz
Prepared release 0.3.20.3.2
It represents the latest state on github, which should be better than what's installed by default. [skip ci]
-rw-r--r--.gitignore1
-rw-r--r--VERSION2
-rw-r--r--doc/source/changes.rst6
-rw-r--r--etc/sublime-text/git-python.sublime-project64
m---------git/ext/gitdb0
-rw-r--r--requirements.txt2
-rwxr-xr-x[-rw-r--r--]setup.py28
7 files changed, 65 insertions, 38 deletions
diff --git a/.gitignore b/.gitignore
index 1a26c03a..2e8e1749 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,7 @@
*.py[co]
*.swp
*~
+/*.egg-info
/lib/GitPython.egg-info
cover/
.coverage
diff --git a/VERSION b/VERSION
index 5a311b4f..d15723fb 100644
--- a/VERSION
+++ b/VERSION
@@ -1 +1 @@
-0.3.2 RC1
+0.3.2
diff --git a/doc/source/changes.rst b/doc/source/changes.rst
index c1e65195..927f326c 100644
--- a/doc/source/changes.rst
+++ b/doc/source/changes.rst
@@ -2,6 +2,12 @@
Changelog
=========
+0.3.2
+=====
+
+* Release of most recent version as non-RC build, just to allow pip to install the latest version right away.
+* Have a look at the milestones (https://github.com/gitpython-developers/GitPython/milestones) to see what's next.
+
0.3.2 RC1
=========
* **git** command wrapper
diff --git a/etc/sublime-text/git-python.sublime-project b/etc/sublime-text/git-python.sublime-project
index 5d981925..d3b69289 100644
--- a/etc/sublime-text/git-python.sublime-project
+++ b/etc/sublime-text/git-python.sublime-project
@@ -35,37 +35,37 @@
"gitdb/ext"
]
},
- // SMMAP
- ////////
- {
- "follow_symlinks": true,
- "path": "../../git/ext/gitdb/gitdb/ext/smmap",
- "file_exclude_patterns" : [
- "*.sublime-workspace",
- ".git",
- ".noseids",
- ".coverage"
- ],
- "folder_exclude_patterns" : [
- ".git",
- "cover",
- ]
- },
- // ASYNC
- ////////
- {
- "follow_symlinks": true,
- "path": "../../git/ext/gitdb/gitdb/ext/async",
- "file_exclude_patterns" : [
- "*.sublime-workspace",
- ".git",
- ".noseids",
- ".coverage"
- ],
- "folder_exclude_patterns" : [
- ".git",
- "cover",
- ]
- },
+ // // SMMAP
+ // ////////
+ // {
+ // "follow_symlinks": true,
+ // "path": "../../git/ext/gitdb/gitdb/ext/smmap",
+ // "file_exclude_patterns" : [
+ // "*.sublime-workspace",
+ // ".git",
+ // ".noseids",
+ // ".coverage"
+ // ],
+ // "folder_exclude_patterns" : [
+ // ".git",
+ // "cover",
+ // ]
+ // },
+ // // ASYNC
+ // ////////
+ // {
+ // "follow_symlinks": true,
+ // "path": "../../git/ext/gitdb/gitdb/ext/async",
+ // "file_exclude_patterns" : [
+ // "*.sublime-workspace",
+ // ".git",
+ // ".noseids",
+ // ".coverage"
+ // ],
+ // "folder_exclude_patterns" : [
+ // ".git",
+ // "cover",
+ // ]
+ // },
]
}
diff --git a/git/ext/gitdb b/git/ext/gitdb
-Subproject 39de1127459b73b862f2b779bb4565ad6b4bd62
+Subproject 2f2fe4eea8ba4f47e63a7392a1f27f74f5ee925
diff --git a/requirements.txt b/requirements.txt
new file mode 100644
index 00000000..c8a4a414
--- /dev/null
+++ b/requirements.txt
@@ -0,0 +1,2 @@
+GitPython
+gitdb >= 0.6.0 \ No newline at end of file
diff --git a/setup.py b/setup.py
index e7c927b1..ed04a581 100644..100755
--- a/setup.py
+++ b/setup.py
@@ -61,6 +61,7 @@ def _stamp_version(filename):
else:
print >> sys.stderr, "WARNING: Couldn't find version line in file %s" % filename
+install_requires = ('gitdb >= 0.6.0',)
setup(name = "GitPython",
cmdclass={'build_py': build_py, 'sdist': sdist},
version = VERSION,
@@ -73,18 +74,35 @@ setup(name = "GitPython",
package_data = {'git.test' : ['fixtures/*']},
package_dir = {'git':'git'},
license = "BSD License",
- install_requires='gitdb >= 0.5.1',
+ requires=('gitdb (>=0.6.0)', ),
+ install_requires=install_requires,
+ test_requirements = ('mock', 'nose') + install_requires,
zip_safe=False,
long_description = """\
GitPython is a python library used to interact with Git repositories""",
- classifiers = [
+ classifiers=[
+ # Picked from
+ # http://pypi.python.org/pypi?:action=list_classifiers
+ #"Development Status :: 1 - Planning",
+ #"Development Status :: 2 - Pre-Alpha",
+ #"Development Status :: 3 - Alpha",
"Development Status :: 4 - Beta",
+ # "Development Status :: 5 - Production/Stable",
+ #"Development Status :: 6 - Mature",
+ #"Development Status :: 7 - Inactive",
+ "Environment :: Console",
"Intended Audience :: Developers",
"License :: OSI Approved :: BSD License",
"Operating System :: OS Independent",
+ "Operating System :: POSIX",
+ "Operating System :: Microsoft :: Windows",
+ "Operating System :: MacOS :: MacOS X",
"Programming Language :: Python",
- "Programming Language :: Python :: 2.5",
+ "Programming Language :: Python :: 2",
"Programming Language :: Python :: 2.6",
- "Topic :: Software Development :: Libraries :: Python Modules",
- ]
+ "Programming Language :: Python :: 2.7",
+ # "Programming Language :: Python :: 3",
+ # "Programming Language :: Python :: 3.3",
+ # "Programming Language :: Python :: 3.4",
+ ]
)