summaryrefslogtreecommitdiff
path: root/.gitignore
diff options
context:
space:
mode:
authorAntoine Musso <hashar@free.fr>2014-07-25 11:01:30 +0200
committerAntoine Musso <hashar@free.fr>2014-07-25 11:20:27 +0200
commit2ddd5e5ef89da7f1e3b3a7d081fbc7f5c46ac11c (patch)
tree82dbc96c2b43f6e188a256b05cc395d99765e165 /.gitignore
parentdbd784b870a878ef6dbecd14310018cdaeda5c6d (diff)
downloadgitpython-2ddd5e5ef89da7f1e3b3a7d081fbc7f5c46ac11c.tar.gz
Use tox to easily run tests in venv
tox https://pypi.python.org/pypi/tox is a thin wrapper around virtualenv which let you craft a fresh python environement to execute command in. It creates the env with virtualenv, install dependencies, run python setup.py install in it and then execute whatever command you want it to do and report status. To do so I simply: - listed tests dependencies in test-requirements.txt (which are just nose and mock) - provide a tox.ini file which describe how to install the dependencies and execute nosetests - added the module 'coverage' to the list of test dependencies To run tests simply: pip install tox && tox That will execute the test command 'nosetests' using python2.6 and then python 2.7. The additional env 'cover' can be run using: tox -ecover.
Diffstat (limited to '.gitignore')
-rw-r--r--.gitignore3
1 files changed, 3 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
index 1a26c03a..f6f85969 100644
--- a/.gitignore
+++ b/.gitignore
@@ -9,3 +9,6 @@ cover/
/doc/_build
nbproject
*.sublime-workspace
+
+/*egg-info
+/.tox