summaryrefslogtreecommitdiff
path: root/.appveyor.yml
diff options
context:
space:
mode:
authorKostis Anagnostopoulos <ankostis@gmail.com>2016-09-26 11:08:57 +0200
committerKostis Anagnostopoulos <ankostis@gmail.com>2016-09-26 20:20:58 +0200
commitfa70623a651d2a0b227202cad1e526e3eeebfa00 (patch)
tree0fdb7195e73f8e26baa155f1651e5303dcb41877 /.appveyor.yml
parent7ec2f8a4f26cec3fbbe1fb447058acaf508b39c0 (diff)
downloadgitpython-fa70623a651d2a0b227202cad1e526e3eeebfa00.tar.gz
test, #519: FIX appveyor conda & failures in py2.6 `assertRaisesRegexp`
Diffstat (limited to '.appveyor.yml')
-rw-r--r--.appveyor.yml13
1 files changed, 8 insertions, 5 deletions
diff --git a/.appveyor.yml b/.appveyor.yml
index 233ea4e3..56669694 100644
--- a/.appveyor.yml
+++ b/.appveyor.yml
@@ -6,17 +6,19 @@ environment:
PYTHON_VERSION: "2.7"
- PYTHON: "C:\\Miniconda"
PYTHON_VERSION: "2.7"
+ IS_CONDA: "yes"
GIT_PATH: "C:\\cygwin\\bin"
- PYTHON: "C:\\Miniconda3-x64"
PYTHON_VERSION: "3.4"
+ IS_CONDA: "yes"
- PYTHON: "C:\\Python34"
PYTHON_VERSION: "3.4"
GIT_PATH: "C:\\cygwin64\\bin"
- - PYTHON: "C:\Python35-x64"
+ - PYTHON: "C:\\Python35-x64"
PYTHON_VERSION: "3.5"
- - PYTHON: "C:\Python35-x64"
+ - PYTHON: "C:\\Python35-x64"
PYTHON_VERSION: "3.5"
GIT_PATH: "C:\\cygwin64\\bin"
@@ -28,12 +30,13 @@ install:
- |
uname -a
where git
+ where python pip pip2 pip3 pip34 pip35 pip36
python --version
python -c "import struct; print(struct.calcsize('P') * 8)"
- - IF EXIST "%PYTHON%\conda.exe" (
+ - IF "%IS_CONDA%"=="yes" (
conda info -a &
- conda install --yes --quiet pip
+ conda install --yes --quiet pip
)
- pip install nose wheel coveralls
- IF "%PYTHON_VERSION%"=="2.7" (
@@ -59,7 +62,7 @@ install:
- python setup.py develop
-build: off
+build: false
test_script:
- "nosetests -v"