summaryrefslogtreecommitdiff
path: root/.appveyor.yml
diff options
context:
space:
mode:
authorJames E. King III <jking@apache.org>2019-01-15 16:16:33 -0500
committerSebastian Thiel <byronimo@gmail.com>2019-05-05 13:22:53 +0530
commitce21f63f7acba9b82cea22790c773e539a39c158 (patch)
tree8c63814a486cee0a66ee092aad90cc3997b1dfd2 /.appveyor.yml
parent1f66e25c25cde2423917ee18c4704fff83b837d1 (diff)
downloadgitpython-ce21f63f7acba9b82cea22790c773e539a39c158.tar.gz
Fix setup.py and use of requirements files.
Diffstat (limited to '.appveyor.yml')
-rw-r--r--.appveyor.yml7
1 files changed, 7 insertions, 0 deletions
diff --git a/.appveyor.yml b/.appveyor.yml
index 8eeca501..2df96e42 100644
--- a/.appveyor.yml
+++ b/.appveyor.yml
@@ -16,6 +16,12 @@ environment:
- PYTHON: "C:\\Python35-x64"
PYTHON_VERSION: "3.5"
GIT_PATH: "%GIT_DAEMON_PATH%"
+ - PYTHON: "C:\\Python36-x64"
+ PYTHON_VERSION: "3.6"
+ GIT_PATH: "%GIT_DAEMON_PATH%"
+ - PYTHON: "C:\\Python37-x64"
+ PYTHON_VERSION: "3.7"
+ GIT_PATH: "%GIT_DAEMON_PATH%"
- PYTHON: "C:\\Miniconda35-x64"
PYTHON_VERSION: "3.5"
IS_CONDA: "yes"
@@ -51,6 +57,7 @@ install:
conda info -a &
conda install --yes --quiet pip
)
+ - pip install -r requirements.txt
- pip install -r test-requirements.txt
- pip install codecov