summaryrefslogtreecommitdiff
path: root/.appveyor.yml
diff options
context:
space:
mode:
authorKostis Anagnostopoulos <ankostis@gmail.com>2016-09-27 23:57:53 +0200
committerKostis Anagnostopoulos <ankostis@gmail.com>2016-09-28 03:35:38 +0200
commit467416356a96148bcb01feb771f6ea20e5215727 (patch)
treeb76b72a024eb285524fc8e846a7ab22aeb243ee4 /.appveyor.yml
parent57550cce417340abcc25b20b83706788328f79bd (diff)
downloadgitpython-467416356a96148bcb01feb771f6ea20e5215727.tar.gz
test: Start using `ddt` library for TCs
+ DataDriven TCs for identifying which separate case failed. + appveyor: rework matrix, conda3.4 cannot install in develop mode
Diffstat (limited to '.appveyor.yml')
-rw-r--r--.appveyor.yml18
1 files changed, 9 insertions, 9 deletions
diff --git a/.appveyor.yml b/.appveyor.yml
index 6f7d3d4a..8ca22ea9 100644
--- a/.appveyor.yml
+++ b/.appveyor.yml
@@ -8,21 +8,17 @@ environment:
- PYTHON: "C:\\Python27"
PYTHON_VERSION: "2.7"
GIT_PATH: "%GIT_DAEMON_PATH%"
- - PYTHON: "C:\\Miniconda"
+ - PYTHON: "C:\\Miniconda-x64"
PYTHON_VERSION: "2.7"
IS_CONDA: "yes"
GIT_PATH: "%CYGWIN_GIT_PATH%"
- PYTHON: "C:\\Python34-x64"
PYTHON_VERSION: "3.4"
- GIT_PATH: "%CYGWIN64_GIT_PATH%"
+ GIT_PATH: "%GIT_DAEMON_PATH%"
- PYTHON: "C:\\Python34-x64"
PYTHON_VERSION: "3.4"
GIT_PATH: "%CYGWIN_GIT_PATH%"
- - PYTHON: "C:\\Miniconda3-x64"
- PYTHON_VERSION: "3.4"
- IS_CONDA: "yes"
- GIT_PATH: "%GIT_DAEMON_PATH%"
- PYTHON: "C:\\Python35-x64"
PYTHON_VERSION: "3.5"
@@ -30,6 +26,10 @@ environment:
- PYTHON: "C:\\Python35-x64"
PYTHON_VERSION: "3.5"
GIT_PATH: "%CYGWIN64_GIT_PATH%"
+ - PYTHON: "C:\\Miniconda35-x64"
+ PYTHON_VERSION: "3.5"
+ IS_CONDA: "yes"
+ GIT_PATH: "%GIT_DAEMON_PATH%"
install:
- set PATH=%PYTHON%;%PYTHON%\Scripts;%GIT_PATH%;%PATH%
@@ -44,9 +44,9 @@ install:
- IF "%IS_CONDA%"=="yes" (
conda info -a &
- conda install --yes --quiet pip smmap
+ conda install --yes --quiet pip
)
- - pip install nose wheel coveralls
+ - pip install nose ddt wheel coveralls
- IF "%PYTHON_VERSION%"=="2.7" (
pip install mock
)
@@ -68,7 +68,7 @@ install:
git config --global user.email "travis@ci.com"
git config --global user.name "Travis Runner"
- - python setup.py develop
+ - pip install -e .
build: false