summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJohn L. Villalovos <john@sodarock.com>2021-11-08 21:03:44 -0800
committerJohn L. Villalovos <john@sodarock.com>2021-11-14 16:14:18 -0800
commit06184daafd5010ba40bb39a0768540b7e98bd171 (patch)
treed943062b06805898b523755a80bac936a868344c /setup.py
parentf7756680d4b1d23ea3216458fb5c6bd73f709d5e (diff)
downloadgitlab-06184daafd5010ba40bb39a0768540b7e98bd171.tar.gz
chore: add type-hints to setup.py and check with mypyjlvillal/mypy_setup
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 5 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 95d60c8..afc7555 100644
--- a/setup.py
+++ b/setup.py
@@ -4,11 +4,14 @@
from setuptools import find_packages, setup
-def get_version():
+def get_version() -> str:
+ version = ""
with open("gitlab/__version__.py") as f:
for line in f:
if line.startswith("__version__"):
- return eval(line.split("=")[-1])
+ version = eval(line.split("=")[-1])
+ break
+ return version
with open("README.rst", "r") as readme_file: