summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorSebastian Thiel <byronimo@gmail.com>2017-09-28 10:52:51 +0200
committerSebastian Thiel <byronimo@gmail.com>2017-09-28 11:01:55 +0200
commit0d5062eac9d03ea63975446439600e63feb83163 (patch)
tree15b819479f9c24d10da3516b994357e93d3251fd /Makefile
parent7f216d9c8954182e978046384e5491840f936216 (diff)
downloadgitdb-0d5062eac9d03ea63975446439600e63feb83163.tar.gz
Upgrade makefile2.0.3
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index c6c159b..8cb323e 100644
--- a/Makefile
+++ b/Makefile
@@ -3,7 +3,21 @@ SETUP = $(PYTHON) setup.py
TESTRUNNER = $(shell which nosetests)
TESTFLAGS =
-all: build
+all::
+ @grep -Ee '^[a-z].*:' Makefile | cut -d: -f1 | grep -vF all
+
+release:: clean
+ # Check if latest tag is the current head we're releasing
+ echo "Latest tag = $$(git tag | sort -nr | head -n1)"
+ echo "HEAD SHA = $$(git rev-parse head)"
+ echo "Latest tag SHA = $$(git tag | sort -nr | head -n1 | xargs git rev-parse)"
+ @test "$$(git rev-parse head)" = "$$(git tag | sort -nr | head -n1 | xargs git rev-parse)"
+ make force_release
+
+force_release:: clean
+ git push --tags
+ python3 setup.py sdist bdist_wheel
+ twine upload -s -i byronimo@gmail.com dist/*
doc::
make -C doc/ html