summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHugo van Kemenade <hugovk@users.noreply.github.com>2022-11-16 18:16:09 +0200
committerHugo van Kemenade <hugovk@users.noreply.github.com>2022-11-16 18:16:09 +0200
commitfaed217d14965932b333c07219ed401a661d2651 (patch)
tree14989f123d3207f5cf5c4a9d8ab5c066085ff6af
parenta6f0856d807efc1e7bc37d13f9cfbcdb91dea2ac (diff)
downloadgitdb-faed217d14965932b333c07219ed401a661d2651.tar.gz
Drop support for EOL Python 3.5 and 3.6
-rw-r--r--.github/workflows/pythonpackage.yml2
-rwxr-xr-xsetup.py3
2 files changed, 2 insertions, 3 deletions
diff --git a/.github/workflows/pythonpackage.yml b/.github/workflows/pythonpackage.yml
index 3c05764..0d039ad 100644
--- a/.github/workflows/pythonpackage.yml
+++ b/.github/workflows/pythonpackage.yml
@@ -15,7 +15,7 @@ jobs:
runs-on: ubuntu-latest
strategy:
matrix:
- python-version: ["3.5", "3.6", "3.7", "3.8", "3.9", "3.10", "3.11"]
+ python-version: ["3.7", "3.8", "3.9", "3.10", "3.11"]
steps:
- uses: actions/checkout@v3
diff --git a/setup.py b/setup.py
index 5d324cd..d38b267 100755
--- a/setup.py
+++ b/setup.py
@@ -22,7 +22,7 @@ setup(
zip_safe=False,
install_requires=['smmap>=3.0.1,<6'],
long_description="""GitDB is a pure-Python git object database""",
- python_requires='>=3.6',
+ python_requires='>=3.7',
# See https://pypi.python.org/pypi?%3Aaction=list_classifiers
classifiers=[
"Development Status :: 5 - Production/Stable",
@@ -35,7 +35,6 @@ setup(
"Operating System :: MacOS :: MacOS X",
"Programming Language :: Python",
"Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
"Programming Language :: Python :: 3.8",
"Programming Language :: Python :: 3.9",