summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Thiel <sebastian.thiel@icloud.com>2021-10-23 08:36:34 +0800
committerSebastian Thiel <sebastian.thiel@icloud.com>2021-10-23 08:36:34 +0800
commit9a289258074fbf92a64186274067a46f7b27666e (patch)
tree82e54bf25d169a43cfd0c068fc966cb75555dc30
parent47a74ca590efbdc3ae59277a491562efa7acc605 (diff)
downloadgitdb-9a289258074fbf92a64186274067a46f7b27666e.tar.gz
Drop support for python 3.4/3.5; make use of smmap 5.0 which does the same4.0.8
-rw-r--r--doc/source/changes.rst8
-rw-r--r--gitdb/__init__.py2
-rwxr-xr-xsetup.py8
3 files changed, 12 insertions, 6 deletions
diff --git a/doc/source/changes.rst b/doc/source/changes.rst
index 1a41d53..de448dd 100644
--- a/doc/source/changes.rst
+++ b/doc/source/changes.rst
@@ -3,6 +3,14 @@ Changelog
#########
*****
+4.0.8
+*****
+
+* drop support for python 3.4 and 3.5 due to EOL
+* Updated upper bound for smmap requirement in setup.py
+ (`#69 <https://github.com/gitpython-developers/gitdb/issues/76>`_)
+
+*****
4.0.7
*****
diff --git a/gitdb/__init__.py b/gitdb/__init__.py
index bef9696..0d936db 100644
--- a/gitdb/__init__.py
+++ b/gitdb/__init__.py
@@ -30,7 +30,7 @@ _init_externals()
__author__ = "Sebastian Thiel"
__contact__ = "byronimo@gmail.com"
__homepage__ = "https://github.com/gitpython-developers/gitdb"
-version_info = (4, 0, 7)
+version_info = (4, 0, 8)
__version__ = '.'.join(str(i) for i in version_info)
diff --git a/setup.py b/setup.py
index 522a88f..251ea93 100755
--- a/setup.py
+++ b/setup.py
@@ -7,7 +7,7 @@ from setuptools import setup
__author__ = "Sebastian Thiel"
__contact__ = "byronimo@gmail.com"
__homepage__ = "https://github.com/gitpython-developers/gitdb"
-version_info = (4, 0, 7)
+version_info = (4, 0, 8)
__version__ = '.'.join(str(i) for i in version_info)
setup(
@@ -20,9 +20,9 @@ setup(
packages=('gitdb', 'gitdb.db', 'gitdb.utils', 'gitdb.test'),
license="BSD License",
zip_safe=False,
- install_requires=['smmap>=3.0.1,<5'],
+ install_requires=['smmap>=3.0.1,<6'],
long_description="""GitDB is a pure-Python git object database""",
- python_requires='>=3.4',
+ python_requires='>=3.6',
# See https://pypi.python.org/pypi?%3Aaction=list_classifiers
classifiers=[
"Development Status :: 5 - Production/Stable",
@@ -35,8 +35,6 @@ setup(
"Operating System :: MacOS :: MacOS X",
"Programming Language :: Python",
"Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.4",
- "Programming Language :: Python :: 3.5",
"Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
"Programming Language :: Python :: 3.8",