summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--tox.ini9
1 files changed, 7 insertions, 2 deletions
diff --git a/tox.ini b/tox.ini
index 27a7c09..54a6ee2 100644
--- a/tox.ini
+++ b/tox.ini
@@ -11,8 +11,11 @@ basepython = python3
install_command = pip install {opts} {packages}
deps = -r{toxinidir}/requirements.txt
-r{toxinidir}/test-requirements.txt
+allowlist_externals = bash
commands =
- python setup.py testr --slowest --testr-args='{posargs}'
+ bash -c "[ -d .testrepository ] || testr init"
+ testr run -- {posargs}
+ testr slowest
[tox:jenkins]
sitepackages = True
@@ -22,8 +25,10 @@ commands = flake8
[testenv:cover]
setenv = VIRTUAL_ENV={envdir}
+allowlist_externals = bash
commands =
- python setup.py testr --coverage
+ bash -c "[ -d .testrepository ] || testr init"
+ testr --coverage
[testenv:venv]
commands = {posargs}