summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Jaeger <aj@suse.com>2016-07-08 10:49:59 +0200
committerAndreas Jaeger <aj@suse.com>2016-07-08 10:51:00 +0200
commitd39384513bc23baf55685a77acb6388616801bf4 (patch)
tree07f6a77cf06707f76cd34f2f49085f5bb1cdc8e7
parent59d29104cb9c370e49b44f313e568bd43b172e1b (diff)
downloadgear-d39384513bc23baf55685a77acb6388616801bf4.tar.gz
List system dependencies for running common tests
Add an other-requirements.txt file containing a cross-platform list of dependencies needed for running included tox-based tests. Also include a tox environment for convenience calling the bindep[*] utility to list any missing system requirements. This change is self-testing. For other-requirements.txt see also http://docs.openstack.org/infra/manual/drivers.html#package-requirements [*] http://docs.openstack.org/infra/bindep/ Change-Id: I165b531c55a6ea27af742fcb3bd995cd4a3dce15
-rw-r--r--other-requirements.txt11
-rw-r--r--tox.ini8
2 files changed, 19 insertions, 0 deletions
diff --git a/other-requirements.txt b/other-requirements.txt
new file mode 100644
index 0000000..fa5c3fb
--- /dev/null
+++ b/other-requirements.txt
@@ -0,0 +1,11 @@
+# This is a cross-platform list tracking distribution packages needed by tests;
+# see http://docs.openstack.org/infra/bindep/ for additional information.
+
+python-dev [platform:dpkg]
+python-devel [platform:rpm]
+python3-all-dev [platform:ubuntu !platform:ubuntu-precise]
+python3-dev [platform:dpkg]
+python3-devel [platform:fedora]
+python3.4 [platform:ubuntu-trusty]
+python3.5 [platform:ubuntu-xenial]
+python34-devel [platform:centos]
diff --git a/tox.ini b/tox.ini
index bf4105b..d99ad32 100644
--- a/tox.ini
+++ b/tox.ini
@@ -35,3 +35,11 @@ select = H231
[testenv:docs]
commands = python setup.py build_sphinx
+
+[testenv:bindep]
+# Do not install any requirements. We want this to be fast and work even if
+# system dependencies are missing, since it's used to tell you what system
+# dependencies are missing! This also means that bindep must be installed
+# separately, outside of the requirements files.
+deps = bindep
+commands = bindep test