summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorClark Boylan <clark.boylan@gmail.com>2022-04-19 10:17:23 -0700
committerClark Boylan <clark.boylan@gmail.com>2022-04-19 10:47:50 -0700
commit9f2d08328ecc8cea1e8b9b10b5aa1d79dff5045c (patch)
tree17bef448f4881988a25fa5f4d455b86b69621137
parentaa21a0c61b1b665714f5b6e55ec202db9ddc22f1 (diff)
downloadgear-9f2d08328ecc8cea1e8b9b10b5aa1d79dff5045c.tar.gz
Fix python3.9 testing
Latest setuptools has deprecated the use of setup.py commands like `setup.py testr`. For some reason python3.9 hangs and fails to work at all when you run `setup.py testr`. Switch to running testr directly and not bother debugging this too aggressively as this functionality is going away eventually. Change-Id: I3ad9e0c00990fbb7d26b03674833666f32b3bcae
-rw-r--r--tox.ini9
1 files changed, 7 insertions, 2 deletions
diff --git a/tox.ini b/tox.ini
index 27a7c09..54a6ee2 100644
--- a/tox.ini
+++ b/tox.ini
@@ -11,8 +11,11 @@ basepython = python3
install_command = pip install {opts} {packages}
deps = -r{toxinidir}/requirements.txt
-r{toxinidir}/test-requirements.txt
+allowlist_externals = bash
commands =
- python setup.py testr --slowest --testr-args='{posargs}'
+ bash -c "[ -d .testrepository ] || testr init"
+ testr run -- {posargs}
+ testr slowest
[tox:jenkins]
sitepackages = True
@@ -22,8 +25,10 @@ commands = flake8
[testenv:cover]
setenv = VIRTUAL_ENV={envdir}
+allowlist_externals = bash
commands =
- python setup.py testr --coverage
+ bash -c "[ -d .testrepository ] || testr init"
+ testr --coverage
[testenv:venv]
commands = {posargs}