summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py34
1 files changed, 4 insertions, 30 deletions
diff --git a/setup.py b/setup.py
index 5b89923..b96e399 100755
--- a/setup.py
+++ b/setup.py
@@ -1,33 +1,7 @@
#!/usr/bin/env python
-from distutils.core import setup
-import os.path
+import setuptools
-description = open(os.path.join(os.path.dirname(__file__), 'README'), 'rt').read()
-
-setup(name="fixtures",
- version="0.3.16",
- description="Fixtures, reusable state for writing clean tests and more.",
- keywords="fixture fixtures unittest contextmanager",
- long_description=description,
- maintainer="Robert Collins",
- maintainer_email="robertc@robertcollins.net",
- url="https://launchpad.net/python-fixtures",
- packages=['fixtures', 'fixtures._fixtures', 'fixtures.tests',
- 'fixtures.tests._fixtures'],
- package_dir = {'':'lib'},
- classifiers = [
- 'Development Status :: 6 - Mature',
- 'Intended Audience :: Developers',
- 'License :: OSI Approved :: BSD License',
- 'License :: OSI Approved :: Apache Software License',
- 'Operating System :: OS Independent',
- 'Programming Language :: Python',
- 'Programming Language :: Python :: 3',
- 'Topic :: Software Development :: Quality Assurance',
- 'Topic :: Software Development :: Testing',
- ],
- requires = [
- 'testtools',
- ],
- )
+setuptools.setup(
+ setup_requires=['pbr'],
+ pbr=True)