summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorColin Watson <cjwatson@ubuntu.com>2022-02-09 10:43:49 +0000
committerGitHub <noreply@github.com>2022-02-09 10:43:49 +0000
commit7aa50f2059dd09cc4321462e5e24310d223c3350 (patch)
tree62ae6faf43293232210a4cd378020031cb51750b
parentf5a07ec2ab0cc02e8f7e8011b3fdae4ed6c4802e (diff)
parentb3de384177622d8b4e8c53e69a39261ccfdb5829 (diff)
downloadfixtures-git-7aa50f2059dd09cc4321462e5e24310d223c3350.tar.gz
Merge pull request #57 from stephenfin/modern-requirements
Update requirements
-rw-r--r--.github/workflows/ci.yaml7
-rw-r--r--requirements.txt4
-rwxr-xr-xsetup.py2
-rw-r--r--tox.ini8
4 files changed, 11 insertions, 10 deletions
diff --git a/.github/workflows/ci.yaml b/.github/workflows/ci.yaml
index 105aec1..6444a72 100644
--- a/.github/workflows/ci.yaml
+++ b/.github/workflows/ci.yaml
@@ -20,9 +20,10 @@ jobs:
with:
python-version: ${{ matrix.python }}
- name: Install dependencies
- run: python -m pip install .[docs,test]
- - name: Run unit tests
- run: make check
+ run: python -m pip install tox
+ - name: Run unit tests (via tox)
+ # Run tox using the version of Python in `PATH`
+ run: tox -e py
docs:
name: Build docs
runs-on: ubuntu-latest
diff --git a/requirements.txt b/requirements.txt
index f9efc61..3a7144a 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -1,2 +1,2 @@
-pbr>=0.11
-testtools>=0.9.22
+pbr>=5.7.0
+testtools>=2.5.0
diff --git a/setup.py b/setup.py
index e6eaf68..4d65eee 100755
--- a/setup.py
+++ b/setup.py
@@ -3,6 +3,6 @@
import setuptools
setuptools.setup(
- setup_requires=['pbr>2.0'],
+ setup_requires=['pbr>5.7.0'],
pbr=True,
)
diff --git a/tox.ini b/tox.ini
index 03546eb..0bba5e2 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,10 +1,10 @@
[tox]
envlist = py36,py37,py38,py39,py310,pypy3
minversion = 3.1
-skipsdist = true
[testenv]
usedevelop = true
-whitelist_externals = make
-deps = .[docs,test]
-commands = make check
+extras =
+ docs
+ test
+commands = python -m testtools.run fixtures.test_suite