summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn W. O'Brien <john@saltant.com>2020-07-28 21:10:30 -0400
committerJohn W. O'Brien <john@saltant.com>2020-07-28 21:10:30 -0400
commit79a49d9803095d9d62984f62265fc7de72c8b4bd (patch)
tree8321428a626511cf6817046d44223a575f2862fd
parentf8924961bdcc042db8bd286f22ba60c787fd8bb7 (diff)
downloadfeedgenerator-79a49d9803095d9d62984f62265fc7de72c8b4bd.tar.gz
Explicitly decode README as UTF-8
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index ca1fedb..76b157d 100644
--- a/setup.py
+++ b/setup.py
@@ -1,5 +1,7 @@
#!/usr/bin/env python
+from io import open
+
# Using setuptools rather than distutils to get the `develop` command
from setuptools import setup
@@ -8,7 +10,7 @@ NAME = 'feedgenerator'
PACKAGES = ['feedgenerator', 'feedgenerator.django',
'feedgenerator.django.utils']
DESCRIPTION = 'Standalone version of django.utils.feedgenerator'
-LONG_DESCRIPTION = open('README.rst').read()
+LONG_DESCRIPTION = open('README.rst', encoding='UTF-8').read()
URL = "https://github.com/getpelican/feedgenerator"