summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHugo van Kemenade <hugovk@users.noreply.github.com>2022-12-02 18:40:41 +0200
committerHugo van Kemenade <hugovk@users.noreply.github.com>2022-12-02 18:40:41 +0200
commit1e48317df1468c2d3550d4251cb5649a407c52cc (patch)
tree4687511c9b825f20866b2237e0ebc4ddb803df5d
parent3c92366d51de24e7d0b54f7606277c06b3ff1876 (diff)
downloadfeedgenerator-1e48317df1468c2d3550d4251cb5649a407c52cc.tar.gz
Add support for Python 3.10 and 3.11
-rw-r--r--.github/workflows/main.yml2
-rw-r--r--setup.py2
-rw-r--r--tox.ini4
3 files changed, 6 insertions, 2 deletions
diff --git a/.github/workflows/main.yml b/.github/workflows/main.yml
index e6ee180..d8b6da8 100644
--- a/.github/workflows/main.yml
+++ b/.github/workflows/main.yml
@@ -11,7 +11,7 @@ jobs:
runs-on: ubuntu-latest
strategy:
matrix:
- python-version: [3.6, 3.7, 3.8, 3.9]
+ python-version: ["3.6", "3.7", "3.8", "3.9", "3.10", "3.11"]
steps:
- uses: actions/checkout@v2
diff --git a/setup.py b/setup.py
index 36e8efb..676a960 100644
--- a/setup.py
+++ b/setup.py
@@ -24,6 +24,8 @@ CLASSIFIERS = ['Development Status :: 5 - Production/Stable',
'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: 3.9',
+ 'Programming Language :: Python :: 3.10',
+ 'Programming Language :: Python :: 3.11',
'Topic :: Internet :: WWW/HTTP',
'Topic :: Internet :: WWW/HTTP :: Dynamic Content',
'Topic :: Software Development :: Libraries :: Python Modules',
diff --git a/tox.ini b/tox.ini
index 8528187..beaf555 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py{3.6,3.7,3.8,3.9}
+envlist = py{3.6,3.7,3.8,3.9,3.10,3.11}
[testenv]
basepython =
@@ -7,6 +7,8 @@ basepython =
py3.7: python3.7
py3.8: python3.8
py3.9: python3.9
+ py3.10: python3.10
+ py3.11: python3.11
commands =
{envpython} --version
pytest