summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Mayer <entroP@gmail.com>2021-08-18 10:35:49 +0200
committerJustin Mayer <entroP@gmail.com>2021-08-18 10:35:49 +0200
commit16c982f987c3948e653839ad50d1c40bcdb2e63f (patch)
treeb3d5ea1c74a163d76e8d2b34cdb7064ad1534f3b
parentae04e8a05b5136eebbc9343137a7e0987737bf50 (diff)
downloadfeedgenerator-16c982f987c3948e653839ad50d1c40bcdb2e63f.tar.gz
Switch Tox to Pytest, supporting Python 3.6 – 3.9
-rw-r--r--setup.py3
-rw-r--r--tox.ini37
2 files changed, 12 insertions, 28 deletions
diff --git a/setup.py b/setup.py
index 76b157d..6b43ea7 100644
--- a/setup.py
+++ b/setup.py
@@ -21,11 +21,10 @@ CLASSIFIERS = ['Development Status :: 5 - Production/Stable',
'License :: OSI Approved :: BSD License',
'Operating System :: OS Independent',
'Programming Language :: Python',
- 'Programming Language :: Python :: 2.7',
- 'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: 3.8',
+ 'Programming Language :: Python :: 3.9',
'Topic :: Internet :: WWW/HTTP',
'Topic :: Internet :: WWW/HTTP :: Dynamic Content',
'Topic :: Software Development :: Libraries :: Python Modules',
diff --git a/tox.ini b/tox.ini
index 417bfe3..ef55f45 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,29 +1,14 @@
[tox]
-envlist = py26,py27,py32,py33,py34,py35
+envlist = py{3.6,3.7,3.8,3.9}
[testenv]
-commands = unit2 discover
-
-[testenv:py26]
-deps =
- unittest2
-
-[testenv:py27]
-deps =
- unittest2
-
-[testenv:py32]
-deps =
- unittest2py3k
-
-[testenv:py33]
-deps =
- unittest2py3k
-
-[testenv:py34]
-deps =
- unittest2py3k
-
-[testenv:py35]
-deps =
- unittest2py3k
+basepython =
+ py3.6: python3.6
+ py3.7: python3.7
+ py3.8: python3.8
+ py3.9: python3.9
+commands =
+ {envpython} --version
+ pytest
+deps =
+ pytest