summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHubert Kario <hubert@kario.pl>2023-02-24 15:41:11 +0100
committerHubert Kario <hubert@kario.pl>2023-02-24 15:41:55 +0100
commit5a114fddcc4c336d53180270d81d6aa42c5ee95b (patch)
tree238dd7584a3f93cc21b44d3ee0e9054a863927d9
parentc2d9fe1d8cc1daaa2036751fc3a41b9ec7b7e140 (diff)
downloadecdsa-5a114fddcc4c336d53180270d81d6aa42c5ee95b.tar.gz
add testing on python 3.12
# Conflicts: # tox.ini
-rw-r--r--.github/workflows/ci.yml4
-rwxr-xr-xsetup.py1
-rw-r--r--tox.ini20
3 files changed, 18 insertions, 7 deletions
diff --git a/.github/workflows/ci.yml b/.github/workflows/ci.yml
index 976359a..8e2920c 100644
--- a/.github/workflows/ci.yml
+++ b/.github/workflows/ci.yml
@@ -83,6 +83,10 @@ jobs:
os: ubuntu-latest
python-version: '3.11'
tox-env: py311
+ - name: py3.12
+ os: ubuntu-latest
+ python-version: '3.12.0-alpha.5'
+ tox-env: py312
- name: pypy
os: ubuntu-latest
python-version: pypy-2.7
diff --git a/setup.py b/setup.py
index 6294117..a9ae243 100755
--- a/setup.py
+++ b/setup.py
@@ -41,6 +41,7 @@ setup(
"Programming Language :: Python :: 3.9",
"Programming Language :: Python :: 3.10",
"Programming Language :: Python :: 3.11",
+ "Programming Language :: Python :: 3.12",
],
install_requires=["six>=1.9.0"],
extras_require={"gmpy2": "gmpy2", "gmpy": "gmpy"},
diff --git a/tox.ini b/tox.ini
index 390b737..c9b07c9 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,17 +1,17 @@
[tox]
-envlist = py26, py27, py35, py36, py37, py38, py39, py310, py311, py, pypy, pypy3, gmpy2py27, gmpy2py39, gmpy2py310, gmpypy27, gmpypy39, gmpypy310, codechecks
+envlist = py26, py27, py35, py36, py37, py38, py39, py310, py311, py312, py, pypy, pypy3, gmpy2py27, gmpy2py39, gmpy2py310, gmpypy27, gmpypy39, gmpypy310, codechecks
[testenv]
deps =
py{26}: unittest2
py{26}: hypothesis<3
- py{26,27,35,36,37,38,39,310,311,py,py3}: pytest
- py{27,35,36,37,38,39,310,311,py,py3}: hypothesis
- gmpy2py{27,39,310,311}: gmpy2
- gmpypy{27,39,310,311}: gmpy
- gmpy{2py27,2py39,2py310,2py311,py27,py39,py310,py311}: pytest
- gmpy{2py27,2py39,2py310,2py311,py27,py39,py310,py311}: hypothesis
+ py{26,27,35,36,37,38,39,310,311,312,py,py3}: pytest
+ py{27,35,36,37,38,39,310,311,312,py,py3}: hypothesis
+ gmpy2py{27,39,310,311,312}: gmpy2
+ gmpypy{27,39,310,311,312}: gmpy
+ gmpy{2py27,2py39,2py310,2py311,2py312,py27,py39,py310,py311,py312}: pytest
+ gmpy{2py27,2py39,2py310,2py311,2py312,py27,py39,py310,py311,py312}: hypothesis
# six==1.9.0 comes from setup.py install_requires
py27_old_six: six==1.9.0
py27_old_six: pytest
@@ -50,6 +50,9 @@ basepython=python3.10
[testenv:gmpypy311]
basepython=python3.11
+[testenv:gmpypy312]
+basepython=python3.12
+
[testenv:gmpy2py27]
basepython=python2.7
@@ -62,6 +65,9 @@ basepython=python3.10
[testenv:gmpy2py311]
basepython=python3.11
+[testenv:gmpy2py312]
+basepython=python3.12
+
[testenv:instrumental]
basepython = python2.7
deps =