summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHubert Kario <hubert@kario.pl>2023-02-23 22:37:29 +0100
committerHubert Kario <hubert@kario.pl>2023-02-24 15:41:50 +0100
commit0edcc812994df273b86f815db66476c22a67969f (patch)
tree22434663b900386336219516716ac9e97181acdd
parent644412d7a27503fb682e7201c57343f3c43b6640 (diff)
downloadecdsa-0edcc812994df273b86f815db66476c22a67969f.tar.gz
Drop support for python 3.3 and python 3.4
As Github actions is dropping support for Ubuntu-18.04 images and those are the only ones that support easy execution of python 3.3 and python 3.4 environments, support for py3.3 and 3.4 would be hard to ensure. For old systems python 2.6 and 2.7 support will remain.
-rw-r--r--.github/workflows/ci.yml8
-rw-r--r--README.md2
-rw-r--r--build-requirements-3.3.txt9
-rw-r--r--build-requirements-3.4.txt7
-rwxr-xr-xsetup.py4
-rw-r--r--src/ecdsa/_compat.py25
-rw-r--r--tox.ini12
7 files changed, 10 insertions, 57 deletions
diff --git a/.github/workflows/ci.yml b/.github/workflows/ci.yml
index 112719c..44c169e 100644
--- a/.github/workflows/ci.yml
+++ b/.github/workflows/ci.yml
@@ -47,14 +47,6 @@ jobs:
os: ubuntu-18.04
python-version: 2.7
tox-env: gmpy2py27
- - name: py3.3
- os: ubuntu-18.04
- python-version: 3.3
- tox-env: py33
- - name: py3.4
- os: ubuntu-18.04
- python-version: 3.4
- tox-env: py34
- name: py3.5
os: ubuntu-18.04
python-version: 3.5
diff --git a/README.md b/README.md
index 11a0016..7cffeb1 100644
--- a/README.md
+++ b/README.md
@@ -45,7 +45,7 @@ curves over prime fields.
## Dependencies
This library uses only Python and the 'six' package. It is compatible with
-Python 2.6, 2.7, and 3.3+. It also supports execution on alternative
+Python 2.6, 2.7, and 3.5+. It also supports execution on alternative
implementations like pypy and pypy3.
If `gmpy2` or `gmpy` is installed, they will be used for faster arithmetic.
diff --git a/build-requirements-3.3.txt b/build-requirements-3.3.txt
deleted file mode 100644
index d817d2b..0000000
--- a/build-requirements-3.3.txt
+++ /dev/null
@@ -1,9 +0,0 @@
-git+https://github.com/tomato42/coveralls-python.git@add-py26#egg=coveralls
-pluggy<0.6
-tox<3
-wheel<0.30
-virtualenv==15.2.0
-enum34
-hypothesis<3.44
-coverage<5.0
-urllib3<=1.25.8
diff --git a/build-requirements-3.4.txt b/build-requirements-3.4.txt
deleted file mode 100644
index ee734d1..0000000
--- a/build-requirements-3.4.txt
+++ /dev/null
@@ -1,7 +0,0 @@
-tox
-git+https://github.com/tomato42/coveralls-python.git@add-py26#egg=coveralls
-hypothesis
-pytest>=4.6.0
-PyYAML<5.3
-coverage
-attrs<21
diff --git a/setup.py b/setup.py
index f6a1dd1..6294117 100755
--- a/setup.py
+++ b/setup.py
@@ -27,15 +27,13 @@ setup(
package_dir={"": "src"},
license="MIT",
cmdclass=commands,
- python_requires=">=2.6, !=3.0.*, !=3.1.*, !=3.2.*",
+ python_requires=">=2.6, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, !=3.4.*",
classifiers=[
"Programming Language :: Python",
"Programming Language :: Python :: 2",
"Programming Language :: Python :: 2.6",
"Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.3",
- "Programming Language :: Python :: 3.4",
"Programming Language :: Python :: 3.5",
"Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
diff --git a/src/ecdsa/_compat.py b/src/ecdsa/_compat.py
index 83d41a5..f409a1a 100644
--- a/src/ecdsa/_compat.py
+++ b/src/ecdsa/_compat.py
@@ -91,28 +91,13 @@ if sys.version_info < (3, 0): # pragma: no branch
raise ValueError("Only 'big' or 'little' endian supported")
else:
- if sys.version_info < (3, 4): # pragma: no branch
- # on python 3.3 hmac.hmac.update() accepts only bytes, on newer
- # versions it does accept memoryview() also
- def hmac_compat(data):
- if not isinstance(data, bytes): # pragma: no branch
- return bytes(data)
- return data
-
- def normalise_bytes(buffer_object):
- """Cast the input into array of bytes."""
- if not buffer_object:
- return b""
- return memoryview(buffer_object).cast("B")
- else:
-
- def hmac_compat(data):
- return data
+ def hmac_compat(data):
+ return data
- def normalise_bytes(buffer_object):
- """Cast the input into array of bytes."""
- return memoryview(buffer_object).cast("B")
+ def normalise_bytes(buffer_object):
+ """Cast the input into array of bytes."""
+ return memoryview(buffer_object).cast("B")
def compat26_str(val):
return val
diff --git a/tox.ini b/tox.ini
index 4686486..390b737 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,18 +1,13 @@
[tox]
-envlist = py26, py27, py33, py34, py35, py36, py37, py38, py39, py310, py311, py, pypy, pypy3, gmpy2py27, gmpy2py39, gmpy2py310, gmpypy27, gmpypy39, gmpypy310, codechecks
+envlist = py26, py27, py35, py36, py37, py38, py39, py310, py311, py, pypy, pypy3, gmpy2py27, gmpy2py39, gmpy2py310, gmpypy27, gmpypy39, gmpypy310, codechecks
[testenv]
deps =
- py{33}: py<1.5
- py{33}: pytest<3.3
- py{33}: enum34
- py{33}: hypothesis<3.44
py{26}: unittest2
py{26}: hypothesis<3
- py{34}: attrs<21
- py{26,27,34,35,36,37,38,39,310,311,py,py3}: pytest
- py{27,34,35,36,37,38,39,310,311,py,py3}: hypothesis
+ py{26,27,35,36,37,38,39,310,311,py,py3}: pytest
+ py{27,35,36,37,38,39,310,311,py,py3}: hypothesis
gmpy2py{27,39,310,311}: gmpy2
gmpypy{27,39,310,311}: gmpy
gmpy{2py27,2py39,2py310,2py311,py27,py39,py310,py311}: pytest
@@ -31,7 +26,6 @@ deps =
py27_old_gmpy2: hypothesis
py: pytest
py: hypothesis
- py{33}: wheel<0.30
coverage
commands = coverage run --branch -m pytest {posargs:src/ecdsa}